zoukankan      html  css  js  c++  java
  • POJ1195--Mobile phones(基础二维BIT)

    Description

    Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

    Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

    Input

    The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

    The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

    Table size: 1 * 1 <= S * S <= 1024 * 1024 
    Cell value V at any time: 0 <= V <= 32767 
    Update amount: -32768 <= A <= 32767 
    No of instructions in input: 3 <= U <= 60002 
    Maximum number of phones in the whole table: M= 2^30 

    Output

    Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

    Sample Input

    0 4
    1 1 2 3
    2 0 0 2 2 
    1 1 1 2
    1 1 2 -1
    2 1 1 2 3 
    3
    

    Sample Output

    3
    4


    #include<iostream>
    using namespace std;
    int s[1030][1030];
    int n;
    int lowbit(int d){
        return d&(-d);
    }
    int getSum(int a,int b){
        int ans=0;
        for(int i=a;i>0;i-=lowbit(i)){
            for(int j=b;j>0;j-=lowbit(j)){
                ans+=s[i][j];
            }
        }    
        return ans;
    }
    void update(int a,int b,int d){
        for(int i=a;i<=n;i+=lowbit(i)){
            for(int j=b;j<=n;j+=lowbit(j)){
                s[i][j]+=d;
            }
        }
    }
    int main(){
        cin>>n>>n;
        int c;
        while(cin>>c&&c!=3){
            if(c==1){
                int x,y,z;
                cin>>x>>y>>z;
                x++;y++;
                update(x,y,z);
            }
            else{
                int w,x,y,z;
                cin>>w>>x>>y>>z;
                w++;x++;y++;z++;
                cout<<getSum(y,z)-getSum(y,x-1)-getSum(w-1,z)+getSum(w-1,x-1)<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    AngularJS--学习笔记(一)
    一行代码写出随机数
    2015最新--浏览器分布图
    JQ系列:css操作
    Eclipse启动Tomcat,45S超时问题解决
    深入理解浏览器兼容性模式
    常见浏览器兼容性问题与解决方案
    面向对象设计模式之一观察者模式
    自定义样式RatingBar的使用
    Python之Matplot——01.堆叠柱状图的绘制
  • 原文地址:https://www.cnblogs.com/albert67/p/10411129.html
Copyright © 2011-2022 走看看