zoukankan      html  css  js  c++  java
  • HDOJ-三部曲-1002-Etaoin Shrdlu

    ContestsProblemsRanklistStatusStatistics

    Etaoin Shrdlu

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
    Total Submission(s) : 59   Accepted Submission(s) : 12
    Problem Description
    The relative frequency of characters in natural language texts is very important for cryptography. However, the statistics vary for different languages. Here are the top 9 characters sorted by their relative frequencies for several common languages: 
    English: ETAOINSHR
     German:  ENIRSATUD
     French:  EAISTNRUL
     Spanish: EAOSNRILD
     Italian: EAIONLRTS
     Finnish: AITNESLOK
    Just as important as the relative frequencies of single characters are those of pairs of characters, so called digrams. Given several text samples, calculate the digrams with the top relative frequencies.
     
    Input
    The input contains several test cases. Each starts with a number n on a separate line, denoting the number of lines of the test case. The input is terminated by n=0. Otherwise, 1<=n<=64, and there follow n lines, each with a maximal length of 80 characters. The concatenation of these n lines, where the end-of-line characters are omitted, gives the text sample you have to examine. The text sample will contain printable ASCII characters only.
     
    Output
    For each test case generate 5 lines containing the top 5 digrams together with their absolute and relative frequencies. Output the latter rounded to a precision of 6 decimal places. If two digrams should have the same frequency, sort them in (ASCII) lexicographical order. Output a blank line after each test case.
     
    Sample Input
    2 Take a look at this!! !!siht ta kool a ekaT 5 P=NP Authors: A. Cookie, N. D. Fortune, L. Shalom Abstract: We give a PTAS algorithm for MaxSAT and apply the PCP-Theorem [3] Let F be a set of clauses. The following PTAS algorithm gives an optimal assignment for F: 0
     
    Sample Output
    a 3 0.073171 !! 3 0.073171 a 3 0.073171 t 2 0.048780 oo 2 0.048780 a 8 0.037209 or 7 0.032558 . 5 0.023256 e 5 0.023256 al 4 0.018605
     
     
     
     
    这题我想了个新方法,以前那个超时的办法就删了。我以各个字符的ASCII码作为数组下标,建立一个二维数组,来存贮各个双字符组合的数量,最后找出数量最大的那五个。
     
     
    #include<iostream>
    #include<string.h>
    #include<iomanip>
    #include<stdio.h>
    using namespace std;
    struct digram
    {
    	char c1,c2;
    	int num;
    }dig[5];                                              //用来存储符合条件的5个双字符组合
    int main()
    {
    	int n,i,j;
    	char s[64][81];
    	while(cin>>n&&n)
    	{
    		getchar();
    		int ascii[128][128]={0},k=0;
    		char let[10000];
    		for(i=0;i<n;i++)
    		{
    			cin.getline(s[i],80);
    			int size=strlen(s[i]);
    			for(j=0;j<size;j++)
    				let[k++]=s[i][j];      //存储各个字符
    		}
    		int total=k-1;                         //双字符总数
    		for(i=0;i<k-1;i++)                     //统计各种双字符组合的个数
    			ascii[let[i]][let[i+1]]++;
    		for(i=0;i<5;i++)                       //寻找符合条件的5个双字符组合
    		{
    			dig[i].num=0;
    			for(j=0;j<128;j++)
    			{
    				for(k=0;k<128;k++)
    					if(dig[i].num<ascii[j][k]||dig[i].num==ascii[j][k]&&(dig[i].c1>j||dig[i].c1==j&&dig[i].c2>k))
    					{
    						dig[i].num=ascii[j][k];
    						dig[i].c1=j;
    						dig[i].c2=k;
    					}
    			}
    			ascii[dig[i].c1][dig[i].c2]=0;
    		}
    		for(i=0;i<5;i++)
    			cout<<dig[i].c1<<dig[i].c2<<' '<<dig[i].num<<' '<<setiosflags(ios::fixed)<<setprecision(6)<<1.0*dig[i].num/total<<endl;
    		cout<<endl;
    	}
    }
    
     
  • 相关阅读:
    牛客练习赛81 B. 小 Q 与彼岸花(DP/Trie/树状数组/FWT/好题)
    HDU6570 Wave(DP)
    HDU6567 Cotree(树的重心/树形DP)
    P1712 [NOI2016] 区间(双指针/线段树)
    P1063 [NOIP2006 提高组] 能量项链(区间DP)
    Jquery
    Jquery
    Jquery
    Jquery 学习
    JS学习
  • 原文地址:https://www.cnblogs.com/aljxy/p/3259046.html
Copyright © 2011-2022 走看看