zoukankan      html  css  js  c++  java
  • Digital Roots

    Digital Roots

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 40226    Accepted Submission(s): 12406


    Problem Description
    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
     
    Input
    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
     
    Output
    For each integer in the input, output its digital root on a separate line of the output.
    Sample Input
    24 39 0
     
    Sample Output
    6 3
     


     
    
    
    测试数据可能很大,所以需要用字符数组存放数据
    
    
    思路:循环遍历若所有位之和大于10,将和重新赋予数组,重复上述步骤,直到所有位之和小于10结束

     
    #include<stdio.h>
    #include<string.h>
    char str[1000];
    int main()
    {
        int sum,k,i,j;
        while(~scanf("%s",str)&&strcmp(str,"0"))
        {
            sum = 0;
            k = strlen(str);
            for(i = 0;i < k;i++)
            {
                sum += str[i]-48;
                if(i==(k-1)&&sum>9)
                {
                    memset(str,0,k);
                    for(j = 0;sum;j++)
                    {
                        str[j] = sum%10+48;
                        sum /= 10;
                    }
                    i = -1;
                    k = j;
                }
            }
            printf("%d ",sum);
        }
        return 0;
    }

    有种更简单的方法:

    #include<stdio.h>
    int main()
    {
     int i,m;
     char s[1000];
     while(scanf("%s",s)==1&&s[0]!='0'){
       for(m=i=0;s[i];i++)
         m+=s[i]-'0';
     printf("%d ",m%9==0?9:m%9);
     }
     return 0;
    }
  • 相关阅读:
    Hello TensorFlow 二 (GPU)
    Hello TensorFlow
    C/C++调用Golang 二
    C/C++调用Golang 一
    再谈cgo(转)
    Go语言第一深坑
    通过样式改变图片明暗度,不是透明度哦
    webpack vue-loader was used without the corresponding plugin. Make sure to include VueLoaderPlugin
    webpack打包报错Chunk.entrypoints: Use Chunks.groupsIterable and filter by instanceof Entrypoint instead
    [Vue warn]: You are using the runtime-only build of Vue where the template compiler is not available. Either pre-compile the templates into render functions, or use the compiler-included build.
  • 原文地址:https://www.cnblogs.com/anhuizhiye/p/3315928.html
Copyright © 2011-2022 走看看