Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7832 Accepted: 2671
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
Source
TUD Programming Contest 2005, Darmstadt, Germany
//
#include <iostream>
using namespace std;
static int step[8][2] = {-2, -1, -2, 1, -1, -2, -1, 2, 1, -2, 1, 2, 2, -1, 2, 1};
bool DFS(int x, int y, int p, int q, bool board[26][26], char path[54], int marked)
{
if (marked == p * q) return true;
int x1, y1;
for (int i = 0; i < 8; ++i)
{
x1 = x + step[i][0];
y1 = y + step[i][1];
if (x1 >= 0 && x1 < q && y1 >= 0 && y1 < p && board[y1][x1] == false)
{
board[y1][x1] = true;
path[(marked<<1)] = x1 + 'A';
path[(marked<<1) + 1] = y1 + '1';
if(DFS(x1,y1,p,q,board,path,marked + 1)) return true;
board[y1][x1] = false;
}
}
return false;
}
int main(int argc, char* argv[])
{
bool board[26][26];
char path[54];
int cases;
cin >> cases;
for (int c = 1; c <= cases; ++c)
{
int p, q;
cin >> p >> q;
memset(board, 0,sizeof(board));
memset(path, 0,sizeof(path));
board[0][0] = true;
path[0] = 'A';
path[1] = '1';
if (DFS(0,0,p,q,board,path,1))
cout << "Scenario #"<<c<<":\n"<<path<<endl<<endl;
else
cout << "Scenario #"<<c<<":\nimpossible\n"<<endl;
};
return 0;
}