zoukankan      html  css  js  c++  java
  • 1002. A+B for Polynomials (25)

    This time, you are supposed to find A+B where A and B are two polynomials.

    Input

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

    Output

    For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

    Sample Input

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    

    Sample Output

    3 2 1.5 1 2.9 0 3.2

    主要存在几个点:
      可以输入重复的项
      输入的项相加后可能为0,此时项数减1
      当项目为0时,只输出项数,不要加空格
      输出最后一项不要加空格
      最终的结果多项式项数最多为20
    #include <stdio.h>
    #include<string.h>
    int main()
    {
        float a[1001];
        int i,k;
        float temp;
        // 初始化数组
        for(i = 0; i <= 1000; i++){
            a[i] = 0.0f;
        }
        // 分别输入两个多项式
        scanf("%d", &k);
        while(k--){
            scanf("%d%f", &i, &temp);
            a[i] += temp;
        }
        scanf("%d", &k);
        while(k--){
            scanf("%d%f", &i, &temp);
            a[i] += temp;
        }
        // 判断当前多项式的项数
        k = 0;
        for(i = 0; i <= 1000; i++){
            if(a[i]!=0.0){
                    k++;
            }
        }
        printf("%d", k);
        // 项数为0则只输出k,且不带空格
        if(k != 0)
            printf(" ");
        for(i=1000; i >= 0; i--){
            if(a[i]!=0.0){
                printf("%d ", i);
                printf("%0.1f", a[i]);
                k--;
                // 输出最后一项后不带空格
                if(k != 0)
                    printf(" ");
            }
        }
        return 0;
    }
  • 相关阅读:
    Maven插件之portable-config-maven-plugin(不同环境打包)
    redis
    MySQL之group_concat 配合substring_index查询
    Jmeter执行测试计划同时监听服务器性能PerfMon Metrics Collector
    【转】证书和编码
    [转]SSL/TLS协议运行机制的概述
    OC—MVC框架图解
    安卓intent
    day8---多线程socket 编程,tcp粘包处理
    day7---socket
  • 原文地址:https://www.cnblogs.com/baichangfu/p/7168221.html
Copyright © 2011-2022 走看看