zoukankan      html  css  js  c++  java
  • hdu Examining the Rooms

    Examining the Rooms

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 365    Accepted Submission(s): 218
     
    Problem Description
    A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc. To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined. Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.
     
    Input
    The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)
     
    Output
    Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.
     
    Sample Input
    3
    3 1
    3 2
    4 2
     
    Sample Output
    0.3333
    0.6667
    0.6250
    Hint
    Sample Explanation When N = 3, there are 6 possible distributions of keys: Room 1 Room 2 Room 3 Destroy Times #1 Key 1 Key 2 Key 3 Impossible #2 Key 1 Key 3 Key 2 Impossible #3 Key 2 Key 1 Key 3 Two #4 Key 3 Key 2 Key 1 Two #5 Key 2 Key 3 Key 1 One #6 Key 3 Key 1 Key 2 One In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1. In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room
     
     
    Source
    The 35th ACM/ICPC Asia Regional Tianjin Site —— Online Contest
     
    Recommend
    lcy
     

    分析:此题为典型的利用DP解决的排列组合数题。本题为第一类斯特林数的应用。状态转移方程: d[i][j] = d[i - 1][j - 1] + d[i - 1][j]*(i - 1),初态:d[k][0]=0,,d[k][k]=1

    #include<cstdio>
    double d[25][25];
    
    void print() {
        int i, j;
        for (i = 0; i <= 20; ++i) {
            d[i][0] = d[0][i] = 0;
            d[i][i] = 1;
        }
        for (i = 1; i <= 20; ++i)
            for (j = 1; j < i; ++j)
                d[i][j] = d[i - 1][j - 1] + d[i - 1][j]*(i - 1);
    }
    
    int main() {
        int T, n, k;
        int i, j;
        double ans;
        print();
        scanf("%d", &T);
        while (T--) {
            scanf("%d%d", &n, &k);
            if(k==1)
            {
                printf("%.4f\n",1.0/n);
                continue;
            }
            ans = 0;
            for (i = k; i >= 1; --i)
                ans += d[n][i] - d[n - 1][i - 1];
            for (j = 2; j <= n; ++j)
                ans /= j;
            printf("%.4f\n", ans);
        }
        return 0;
    }
  • 相关阅读:
    SpringBoot异步处理请求
    5本最佳的 Java 面向对象理论和设计模式的书籍
    彻底弄懂 HTTP 缓存机制 —— 基于缓存策略三要素分解法
    Java 性能优化的五大技巧
    Java 8 最佳技巧
    Java 并发的四种风味:Thread、Executor、ForkJoin 和 Actor
    在 Java 8 中避免 Null 检查
    关于创建java线程池问题的思考
    LuoguP1858 多人背包(DP)
    Luogu[YNOI2019]排序(DP,线段树)
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2664447.html
Copyright © 2011-2022 走看看