zoukankan      html  css  js  c++  java
  • hdu 50 years, 50 colors

    50 years, 50 colors

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 39    Accepted Submission(s): 33
     
    Problem Description
    On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".
    There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.
    Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.
     
    Input
    There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
     
    Output
    For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
     
    Sample Input
    1 1
    1
    2 1
    1 1
    1 2
    2 1
    1 2
    2 2
    5 4
    1 2 3 4 5
    2 3 4 5 1
    3 4 5 1 2
    4 5 1 2 3
    5 1 2 3 4
    3 3
    50 50 50
    50 50 50
    50 50 50
    0 0
     
    Sample Output
    -1
    1
    2
    1 2 3 4 5
    -1
     
    Author
    8600
     
    Source
    “2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛
     
    Recommend
    LL
     

    分析:二分图中,行为左,列为右,每条连边代表该行该列有一个气球。问题转化为求最大匹配。

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int map[110][110], match[110], vis[110], have[60], ans[60];
    int color, n;
    
    int dfs(int a) {
        int i;
        for (i = 1; i <= n; ++i) {
            if (map[a][i] != color || vis[i])
                continue;
            vis[i] = 1;
            if (match[i] == -1 || dfs(match[i])) {
                match[i] = a;
                return 1;
            }
        }
        return 0;
    }
    
    int main() {
        int k, i, j, cnt, max;
        while (scanf("%d%d", &n, &k) != EOF && n) {
            cnt = 0;
            memset(have, 0, sizeof (have));
            for (i = 1; i <= n; ++i) {
                for (j = 1; j <= n; ++j) {
                    scanf("%d", &map[i][j]);
                    have[map[i][j]] = 1;
                }
            }
            for (color = 1; color <= 50; ++color) {
                if (!have[color])
                    continue;
                max = 0;
                memset(match, -1, sizeof (match));
                for (i = 1; i <= n; ++i) {
                    memset(vis, 0, sizeof (vis));
                    if (dfs(i)) {
                        ++max;
                    }
                }
                if (max > k) {
                    ans[cnt++] = color;
                }
            }
            if (cnt == 0)
                printf("-1\n");
            else {
                sort(ans, ans + cnt);
                for (i = 0; i < cnt - 1; ++i)
                    printf("%d ", ans[i]);
                printf("%d\n", ans[i]);
            }
        }
        return 0;
    }
    这条路我们走的太匆忙~拥抱着并不真实的欲望~
  • 相关阅读:
    疑似CPU或者内存故障导致进程崩溃
    free如何知道释放内存长度:vs与glibc分配内存时编译器内部处理
    stun简介
    H264(NAL简介与I帧判断)
    H264码率设置
    简单的makefile模板
    ffmpeg显示视频
    一些yuv视频下载地址
    转载:P2P技术原理及应用(2)
    转载:P2P技术原理及应用(1)
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2710064.html
Copyright © 2011-2022 走看看