zoukankan      html  css  js  c++  java
  • 设置是否广告问题

    问题:

    Input
    The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106. 


    Output
    Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference. 


    Sample Input
    3
    0 100 70
    100 130 30
    -100 -70 40


    Sample Output
    advertise
    does not matter
    do not advertise

    回答:

    #include<iostream>  
    using namespace std;  
    int main()  
    {  
        int t,r,e,c;  
        while(scanf("%d",&t)!=EOF)  
        {  
            while(t--)  
            {  
                scanf("%d%d%d",&r,&e,&c);  
                if(r>(e-c))printf("do not advertise ");  
                else if(r<(e-c))printf("advertise ");  
                else printf("does not matter ");  
            }  
     
        }  
        return 0;  
    }

  • 相关阅读:
    js通过class获取元素时的兼容性解决方案
    html5的八大特性
    typeof与instanceof的区别
    evel()与JSON.parset()的区别
    apt-get出现的问题
    Linux下开启计划任务日志
    ls
    win10自带IE上不了网的解决办法
    crontab -e文件存放路径
    Linux系统下面crontab选择默认编译器
  • 原文地址:https://www.cnblogs.com/benchao/p/4494848.html
Copyright © 2011-2022 走看看