zoukankan      html  css  js  c++  java
  • 1014.排名

    题目描述:
        今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的考生,并将他们的成绩按降序打印。
    输入:

        测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号(题目号由1到M)。 
        当读入的考生人数为0时,输入结束,该场考试不予处理。

    输出:

        对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考号的升序输出。

    样例输入:
    4 5 25
    10 10 12 13 15
    CS004 3 5 1 3
    CS003 5 2 4 1 3 5
    CS002 2 1 2
    CS001 3 2 3 5
    1 2 40
    10 30
    CS001 1 2
    2 3 20
    10 10 10
    CS000000000000000001 0
    CS000000000000000002 2 1 2
    0
    样例输出:
    3
    CS003 60
    CS001 37
    CS004 37
    0
    1
    CS000000000000000002 20
    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    struct student{
        char id[50];
        int k;
        int v[11];
        int score;
        bool line;
    };
    
    student b[1001];
    
    bool com(student g,student h){
            if(g.score!=h.score) return g.score>h.score;
            else {
                for(int i=0;i<10;i++){
                    if(g.id[i]!=h.id[i]) return g.id[i]<h.id[i];
                }
            }
    }
    int main(){
        int n,m,g,i,j;
        while(cin>>n){
            int a[11]={0};
            for(i=0;i<1001;i++){
                b[i].score=0;
                b[i].line=false;
            }
            if(n==0) return 0;
            else{
            cin>>m>>g;
            for(i=1;i<=m;i++){
                cin>>a[i];
            }
            for(i=0;i<n;i++){
                cin>>b[i].id>>b[i].k;
                for(j=0;j<b[i].k;j++){
                    cin>>b[i].v[j];
                }
            }
            for(i=0;i<n;i++){
                for(j=0;j<b[i].k;j++)
                b[i].score+=a[b[i].v[j]];
            }
            for(i=0;i<n;i++){
                if(b[i].score>=g) b[i].line=true;
            }
            sort(b,b+n,com);
            int num=0;
            for(i=0;i<n;i++){
                if(b[i].line==true) num++;
            }
            cout<<num<<endl;
            for(i=0;i<n;i++){
                if(b[i].line==true) cout<<b[i].id<<" "<<b[i].score<<endl;
            }
        }
    }
    return 0;
    }
  • 相关阅读:
    信息系统项目管理师沟通的四个好习惯
    Android 线程
    替换exe程序图标DLL
    Python 邮件类
    android自适应屏幕方向和大小
    sqlserver 存储过程
    FinalData 数据恢复工具[绿色版]
    Python Python 正则 取中括号值
    在Button任意位置加图片效果
    android GPRS
  • 原文地址:https://www.cnblogs.com/bernieloveslife/p/9736628.html
Copyright © 2011-2022 走看看