zoukankan      html  css  js  c++  java
  • poj1002 487-3279

    Description

    Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

    The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

    A, B, and C map to 2 
    D, E, and F map to 3 
    G, H, and I map to 4 
    J, K, and L map to 5 
    M, N, and O map to 6 
    P, R, and S map to 7 
    T, U, and V map to 8 
    W, X, and Y map to 9 

    There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

    Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

    Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

    Input

    The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

    Output

    Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

    No duplicates. 

    Sample Input

    12
    4873279
    ITS-EASY
    888-4567
    3-10-10-10
    888-GLOP
    TUT-GLOP
    967-11-11
    310-GINO
    F101010
    888-1200
    -4-8-7-3-2-7-9-
    487-3279
                

    Sample Output

    310-1010 2
    487-3279 4
    888-4567 3
    import java.io.BufferedInputStream;   
    import java.io.DataInputStream;   
    import java.io.IOException;   
    import java.util.Iterator;   
    import java.util.Map;   
    import java.util.Scanner;   
    import java.util.Set;   
    import java.util.TreeMap;   
    public class Main {   
      
        public static char getNum(char c) {   
            if (Character.isDigit(c)) {   
                return c;   
            }   
            if (c == 'A' || c == 'B' || c == 'C') {   
                return '2';   
            }   
            if (c == 'D' || c == 'E' || c == 'F') {   
                return '3';   
            }   
            if (c == 'G' || c == 'H' || c == 'I') {   
                return '4';   
            }   
            if (c == 'J' || c == 'K' || c == 'L') {   
                return '5';   
            }   
            if (c == 'M' || c == 'N' || c == 'O') {   
                return '6';   
            }   
            if (c == 'P' || c == 'R' || c == 'S') {   
                return '7';   
            }   
            if (c == 'T' || c == 'U' || c == 'V') {   
                return '8';   
            }   
            if (c == 'W' || c == 'X' || c == 'Y') {   
                return '9';   
            }   
            return '#';   
        }   
      
        public static void main(String[] args) throws IOException {   
            DataInputStream scan = new DataInputStream(new BufferedInputStream(System.in));   
            Map< String, Integer> tm = new TreeMap();   
            int n = Integer.parseInt(scan.readLine().trim());
            for (int i = 0; i < n; i++) {   
                String s = scan.readLine().replace("-", "");   
                StringBuilder sb = new StringBuilder();   
                for (int k = 0; k < s.length(); k++) {   
                    char c = getNum(s.charAt(k));   
                    if (Character.isDigit(c)) {   
                        sb.append(c);   
                    }   
                }   
                String result = sb.toString().substring(0, 3) + '-' + sb.toString().substring(3);   
                if (tm.containsKey(result)) {   
                    int count = tm.get(result) + 1;   
                    tm.put(result, count);   
                } else {   
                    tm.put(result, 1);   
                }   
            }   
            Set se = tm.keySet();   
            Iterator it = se.iterator();   
            boolean flag = false;   
            while (it.hasNext()) {   
                String s = it.next().toString();   
                int count = tm.get(s);   
                if (count > 1) {   
                    flag = true;   
                    System.out.println(s + " " + count);   
                }   
            }   
            if (!flag) {   
                System.out.println("No duplicates. ");   
            }   
        }   
    }  
  • 相关阅读:
    提取汉字首字母助手类:
    ComboBox1获取datatable的一列
    C++容器
    字符串反转
    什么是C++标准库
    如何在程序中使用系统调用
    秒针、分针和时针的重合次数(十二小时)
    查找单向链表倒数第n个元素
    Ubuntu下查看计算机信息
    实验三:给系统添加一个新的系统调用
  • 原文地址:https://www.cnblogs.com/bigjava/p/3928342.html
Copyright © 2011-2022 走看看