zoukankan      html  css  js  c++  java
  • 1036 Boys vs Girls (25 分)

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​​gradeM​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA
    
    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    struct student
    {
        string name;
        char sex;
        string id;
        int grade;
    };
    bool cmp(student a,student b)
    {
        return a.grade>b.grade;
    }
    int main()
    {
        int n;
        vector<student> boy;
        vector<student> girl;
        student temp;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>temp.name>>temp.sex>>temp.id>>temp.grade;
            if(temp.sex == 'F')
                girl.push_back(temp);
            else
                boy.push_back(temp);
           // scanf("%s%s%s%d",&stu[i].name,&stu[i].sex,&stu[i].id,&stu[i].grade);
        }
        //sort(student,student+n);
        sort(boy.begin(),boy.end(),cmp);
        sort(girl.begin(),girl.end(),cmp);
        if(girl.size()==0)
            cout<<"Absent"<<endl;
        else
            cout<<girl[0].name<<' '<<girl[0].id<<endl;
        if(boy.size()==0)
            cout<<"Absent"<<endl;
        else
            cout<<boy[boy.size()-1].name<<' '<<boy[boy.size()-1].id<<endl;
        if(girl.size() == 0 || boy.size() == 0)
            cout<<"NA"<<endl;
        else
            cout<<abs(boy[boy.size() -1].grade - girl[0].grade)<<endl;
        return 0;
    }
  • 相关阅读:
    Forms身份验证和基于Role的权限验证
    构建高扩展性网站
    多态和继承(继承)
    MVC使用Bootstrap
    使用Navicat Premium 和PLSQL Developer连接Oracl
    内存排查 valgrind
    MVC Bootstrap Helpers
    IOS各种调试
    JavaScript 奇技淫巧
    深入理解Linux修改hostname(转)
  • 原文地址:https://www.cnblogs.com/binanry/p/10013455.html
Copyright © 2011-2022 走看看