zoukankan      html  css  js  c++  java
  • [BestCoder Round #5] hdu 4956 Poor Hanamichi (数学题)

    Poor Hanamichi


    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 743    Accepted Submission(s): 275


    Problem Description
    Hanamichi is taking part in a programming contest, and he is assigned to solve a special problem as follow: Given a range [l, r] (including l and r), find out how many numbers in this range have the property: the sum of its odd digits is smaller than the sum of its even digits and the difference is 3. A integer X can be represented in decimal as: X=An×10n+An1×10n1++A2×102+A1×101+A0 The odd dights are A1,A3,A5 and A0,A2,A4 are even digits. Hanamichi comes up with a solution, He notices that: 102k+1 mod 11 = -1 (or 10), 102k mod 11 = 1, So X mod 11 = (An×10n+An1×10n1++A2×102+A1×101+A0)mod11 = An×(1)n+An1×(1)n1++A2A1+A0 = sum_of_even_digits – sum_of_odd_digits So he claimed that the answer is the number of numbers X in the range which satisfy the function: X mod 11 = 3. He calculate the answer in this way : Answer = (r + 8) / 11 – (l – 1 + 8) / 11. Rukaw heard of Hanamichi’s solution from you and he proved there is something wrong with Hanamichi’s solution. So he decided to change the test data so that Hanamichi’s solution can not pass any single test. And he asks you to do that for him.
     
    Input
    You are given a integer T (1 ≤ T ≤ 100), which tells how many single tests the final test data has. And for the following T lines, each line contains two integers l and r, which are the original test data. (1 ≤ l ≤ r ≤ 1018)
     
    Output
    You are only allowed to change the value of r to a integer R which is not greater than the original r (and R ≥ l should be satisfied) and make Hanamichi’s solution fails this test data. If you can do that, output a single number each line, which is the smallest R you find. If not, just output -1 instead.
     
    Sample Input
    3 3 4 2 50 7 83
     
    Sample Output
    -1 -1 80

    解题思路:

    题意为:存在一个问题求一个区间([l,r])内有多少数满足(偶数位的和-奇数位的和==3)。

    Hanamichi提出了它的解法 Answer =  (r + 8) / 11 – (l – 1 + 8) / 11.我们的任务就是找到一个最小的右端点,使得该区间内满足条件的数不满足Hanamichi的解法。

    一開始读完题意想的是数位Dp,但后来用暴力搞了.....

    代码:

    #include <iostream>
    using namespace std;
    
    long long cal(long long l,long long r)//常规方法求区间内满足条件的数有多少个
    {
        long long result=0;
        for(;l<=r;l++)
        {
            long long temp=l;
            int mul=1;
            int re=0;
            while(temp)
            {
                re+=mul*(temp%10);
                temp/=10;
                mul=(-mul);
            }
            if(re==3)
                result++;
        }
        return result;
    }
    
    long long re(long long l,long long r)
    {
        return (r+8)/11-(l-1+8)/11;
    }
    
    int main()
    {
        long long l,r,R;
        int t;
        cin>>t;
        while(t--)
        {
            cin>>l>>r;
            for(R=l;R<=r;R++)//从小到大,输出最小的那个
            {
                long long result=re(l,R);
                if(cal(l,R)!=result)
                {
                    cout<<R<<endl;
                    break;
                }
            }
            if(R>r)
                cout<<-1<<endl;
        }
        return 0;
    }
    


     

     

  • 相关阅读:
    Django ORM中常用的字段类型以及参数配置
    python enumerate用法总结
    Django 模板渲染
    Django null=True和blank=True的区别
    Django下关于session的使用
    方程组法求函数的解析式
    求数列通项公式的小众方法
    不等式性质
    多项选择题
    对勾型函数
  • 原文地址:https://www.cnblogs.com/blfbuaa/p/6697494.html
Copyright © 2011-2022 走看看