zoukankan      html  css  js  c++  java
  • poj 2524 Ubiquitous Religions(并查集)

    Ubiquitous Religions
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 23168   Accepted: 11404

    Description

    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

    Input

    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

    Output

    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

    Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 7
    

    Hint

    Huge input, scanf is recommended.

    Source

    又一并查集水题  直接套用模板  不多做解释

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int father[50005];
    int find(int x)//找与x相关联的人
    {
        while(x!=father[x])//找到人
            x=father[x];
        return x;
    }
    void getfind(int a,int b)
    {
        int roota=find(a);
        int rootb=find(b);
        if(roota!=rootb)当roota和rootb不在同一集合时将其合并
            father[rootb]=roota;
    }
    int main()
    {
        int n,m,i,j,a,b;
        int t=1;
        while(cin>>n>>m,n&&m)
        {
    
            for(i=1;i<=n;i++)
            father[i]=i;
            for(i=0;i<m;i++)
                {
                    cin>>a>>b;
                   getfind(a,b);
                }
    
                int ans=0;
                for(i=1;i<=n;i++)
                    //cout<<father[i]<<" "<<endl;
                    if(father[i]==i)
                        ans++;
                    cout<<"Case "<<t<<": "<<ans<<endl;
                    t++;
        }
    
    }
    


  • 相关阅读:
    致初学作曲的业余音乐爱好者 (转载)
    OpenGL教程 "Top Ten" (转载)
    开发者:我们应该在哪个层次编写代码?
    计算机科学数学理论浅谈 (转载)
    fltk2更新简介
    搜集的优良OpenGL教程 (转载)
    [转载] 跨平台C++程序开发系列文章
    通过HtppWebRequest发送图片到服务器并保存
    技术之外
    Hibernate写查询语句注意事项
  • 原文地址:https://www.cnblogs.com/blfbuaa/p/6763562.html
Copyright © 2011-2022 走看看