zoukankan      html  css  js  c++  java
  • POJ 3253 Fence Repair(哈夫曼树)

    Fence Repair
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 26167   Accepted: 8459

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

    Source




    #include <iostream>
    using namespace std;
    #define maxn 20010
    long long int n;//目标板数
    long long int len;//堆长
    long long int p[maxn];//堆
    void swap(long long int &a,long long int &b)
    {
        long long int temp;
        temp=a;
        a=b;
        b=temp;
    }
    void heap_insert(long long int k)//将k插入到小根堆中。并维护堆性质
    {
        long long int t=++len;//将k插入到堆尾
        p[t]=k;
        while(t>1)//自上而下将k调整到合适的位置
        {
            if(p[t/2]>p[t])//若t的值大于其父节点的值,则交换。继续向上调整
            {
                swap(p[t/2],p[t]);
                t=t/2;
            }
            else
                break;
        }
    }
    
    void heap_pop()
    {
        long long int t=1;//将堆尾元素移到堆首
        p[t]=p[len--];
        while(2*t<=len)//调整堆首元素到合适位置,自上而下调整
        {
            long long int k=2*t;
            if(k<len&&p[k]>p[k+1])//计算左右儿子中较小的节点序号k
                k=k+1;
            if(p[t]>p[k])
            {
                swap(p[t],p[k]);
                t=k;
            }
            else
                break;
        }
    }
    int main()
    {
        cin>>n;
    
        long long int i;
        for(i=1;i<=n;i++)
            cin>>p[i];
    
        for(i=1;i<=n;i++)
            heap_insert(p[i]);//将n块木板的长度增加小根堆
    
        long long int ans;//最小费用
        ans=0;
    
        while(len>1)//构造哈夫曼树
        {
            long long int a,b;
            a=p[1];//取堆首节点(权值a)。并维护其性质
            heap_pop();
    
            b=p[1];
            heap_pop();
    
            ans=ans+a+b;//将a和b累计计入最小费用中
            heap_insert(a+b);//合并成一个权值插入到小根堆
        }
        cout <<ans<<endl;
        return 0;
    }
    


  • 相关阅读:
    训练赛
    树形dp专题
    返回的中文乱码问题
    富文本内容放在xml标签中;
    xml 截取 标签中的字符串;字符串去掉空格
    Intetn 传输 (2)
    安卓修改标题栏
    简单的数据存储(SharedPreferences.Editor)
    Intent的数据传输
    python实现快排+冒泡排序
  • 原文地址:https://www.cnblogs.com/blfbuaa/p/6773023.html
Copyright © 2011-2022 走看看