zoukankan      html  css  js  c++  java
  • ZOJ Anagrams by Stack(堆栈中的搜索)

    个人心得:算法书中的第一个例题就来了一个下马威,虽然题意很好理解但是做起来确实这么不顺手,所以自己对于搜索和堆栈理解的并不是很好,

    以前也是很多这样的题目无法实施,这题要做的很明确就是输出正确的能依靠栈完成字符串的变化,很明显答案很多所以必须搜索确定出栈的位置,

    但是自己无法控制好搜索,题解很清晰,

    个人收获:vector 可以用于搜索更方便,然后搜索的时候注意细节和base基准情况

    题目:

    How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

    [
    i i i i o o o o
    i o i i o o i o
    ]
    

    where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

    Input

    The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

    Output

    For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

    [
    ]
    

    and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

    Process

    A stack is a data storage and retrieval structure permitting two operations:

    Push - to insert an item and Pop - to retrieve the most recently pushed item

    We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

    i i o i o o is valid, but
    i i o is not (it's too short), neither is
    i i o o o i (there's an illegal pop of an empty stack)

    Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

    Sample Input

    madam
    adamm
    bahama
    bahama
    long
    short
    eric
    rice
    

    Sample Output

    [
    i i i i o o o i o o 
    i i i i o o o o i o 
    i i o i o i o i o o 
    i i o i o i o o i o 
    ]
    [
    i o i i i o o i i o o o 
    i o i i i o o o i o i o 
    i o i o i o i i i o o o 
    i o i o i o i o i o i o 
    ]
    [
    ]
    [
    i i o i o i o o 
    ]
    #include<iostream>
    #include<cstring>
    #include<string>
    #include<cstdio>
    #include<vector>
    #include<cmath>
    #include<stack>
    #include<set>
    #include<queue>
    #include<algorithm>
    using namespace std;
    string a,b;
    stack<char >build;
    vector<char >operate;
    int length;
    void dfs(int ipush,int ipop){
          if(ipush==length&&ipop==length)
          {
              for(int i=0;i<operate.size();i++)
                cout<<operate[i]<<" ";
              cout<<endl;
          }
          if(ipush+1<=length)
          {
              build.push(a[ipush]);
              operate.push_back('i');
              dfs(ipush+1,ipop);
              build.pop();
              operate.pop_back();
          }
          if(ipop+1<=ipush&&ipop+1<=length&&build.top()==b[ipop]){
            char tc=build.top();
            build.pop();
            operate.push_back('o');
            dfs(ipush,ipop+1);
            build.push(tc);
            operate.pop_back();
          }
    }
    int main()
    {
        while(cin>>a>>b){
            length=a.length();
            cout<<"["<<endl;
            dfs(0,0);
            cout<<"]"<<endl;
        }
        return 0;
    }
    View Code


  • 相关阅读:
    sql中触发器的使用
    sql中优化查询
    sql中case when语句的使用
    CSRF学习小结
    javascript正则表达式笔记
    elementUI单选框获取值
    elementUI内置过渡(折叠)
    elementUI内置缩放过渡(缩放)
    elementUi内置过渡动画(淡入)
    创建koa2项目
  • 原文地址:https://www.cnblogs.com/blvt/p/7756106.html
Copyright © 2011-2022 走看看