zoukankan      html  css  js  c++  java
  • PAT 1001

    Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

    Input

    Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

    Output

    For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

    Sample Input
    -1000000 9 
    Sample Output
    -999,991 

    主要注意两点 :

    1. 输出时要注意逗号,如1000要输出1,000
    2. 要注意后面部分数字的前置0,如1010,要输出1,010,而不是1,10
    代码
     1 #include <stdio.h>
     2 int main()
     3 {
     4     int a,b,sum;
     5     int arr[5];
     6     while(scanf("%d%d",&a,&b) != EOF){
     7         sum = a+b;
     8         if(sum == 0){
     9             printf("0 ");
    10             break;
    11         }
    12         else if(sum < 0){
    13             printf("-");
    14             sum = sum * -1;
    15         }
    16         int i = 0;
    17         while(sum){
    18             arr[i++] = sum % 1000;
    19             sum = sum / 1000;
    20         }
    21         printf("%d",arr[--i]);
    22         for(--i;i >= 0;--i){
    23             printf(",%03d",arr[i]);
    24         }
    25         printf(" ");
    26     }
    27     return 0;
    28 }

  • 相关阅读:
    关于react fiber的理解
    前段框架——VueX
    前段框架——Vue组件间传值
    前段框架——Vue的get和post请求数据
    前段框架——Vue的一级路由和二级路由
    前端框架——Vue脚手架
    前段框架——Vue
    关于Tomcat的BUG
    验证身份证号格式
    mysql 占用90%多的CPU,解决思路
  • 原文地址:https://www.cnblogs.com/boostable/p/pat_1001.html
Copyright © 2011-2022 走看看