zoukankan      html  css  js  c++  java
  • PAT 1008

    1008. Elevator (20)

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:
    3 2 3 1 
    Sample Output:
    41 

    直接上代码

     1 #include <stdio.h>
     2 
     3 int main()
     4 {
     5     int N;
     6     int sum;
     7     int i;
     8     int start_pos,end_pos;
     9     while(scanf("%d",&N) != EOF){
    10         sum = 0;
    11         start_pos = 0;
    12         for(i=0;i<N;++i){
    13             scanf("%d",&end_pos);
    14             if(start_pos < end_pos){
    15                 sum = sum + 6 * (end_pos - start_pos);
    16             }
    17             else{
    18                 sum = sum + 4 * (start_pos - end_pos);
    19             }
    20             start_pos = end_pos;
    21         }
    22         sum = sum + 5 * N;
    23         printf("%d ",sum);
    24     }
    25     return 0;
    26 }

  • 相关阅读:
    Java 泛型
    face_recognition
    用于图像分割的卷积神经网络:从R-CNN到Mark R-CNN
    OpenCV探索
    基于深度学习的目标检测技术演进:R-CNN、Fast R-CNN、Faster R-CNN
    卷积神经网络CNN总结
    (4)Smali系列学习之Smali语法详解内部类
    log4j的配置信息
    C#的async和await
    Java魔法堂:String.format详解
  • 原文地址:https://www.cnblogs.com/boostable/p/pat_1008.html
Copyright © 2011-2022 走看看