zoukankan      html  css  js  c++  java
  • POJ 2151 Check the difficulty of problems(概率dp)

    Language:
    Check the difficulty of problems
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 5419   Accepted: 2384

    Description

    Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
    1. All of the teams solve at least one problem. 
    2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

    Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

    Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

     

    Input

    The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

    Output

    For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

    Sample Input

    2 2 2
    0.9 0.9
    1 0.9
    0 0 0
    

    Sample Output

    0.972

    Source

    POJ Monthly,鲁小石


    题意: n个人,m道题,求每一个人做出题,而且至少一个做出k道题的概率

    思路:等于每一个人做出题的概率--每一个人做出题而且没有一个人做出k到题的概率


    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<set>
    #include<map>
    
    
    #define L(x) (x<<1)
    #define R(x) (x<<1|1)
    #define MID(x,y) ((x+y)>>1)
    
    #define eps 1e-8
    typedef __int64 ll;
    
    #define fre(i,a,b)  for(i = a; i < b; i++)
    #define free(i,b,a) for(i = b; i >= a;i--)
    #define mem(t, v)   memset ((t) , v, sizeof(t))
    #define ssf(n)      scanf("%s", n)
    #define sf(n)       scanf("%d", &n)
    #define sff(a,b)    scanf("%d %d", &a, &b)
    #define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
    #define pf          printf
    #define bug         pf("Hi
    ")
    
    using namespace std;
    
    #define INF 0x3f3f3f3f
    #define N 1005
    
    double dp[N][35][35];  // dp[i][j][k]  第 i 个人 前 j 道题 做 k 道概率
    double p[N][35];
    int n,m,k;
    
    void solve()
    {
    	int i,j,t;
    	mem(dp,0);
    
        fre(i,1,n+1)         //初始每个人第一道题 对 与不正确
          {
          	dp[i][1][0]=1-p[i][1];
    		dp[i][1][1]=p[i][1];
          }
    
    	fre(i,1,n+1)         //每个人m到题都没有作对
    	 {
    	 	fre(j,2,m+1)
    		  dp[i][j][0]=dp[i][j-1][0]*(1-p[i][j]);
    	 }
    
    	fre(i,1,n+1)        //每个人j道题 做t道概率
    	 fre(j,2,m+1)
    	  fre(t,1,j+1)
    	 {
           if(t<j)
    		 dp[i][j][t]=dp[i][j-1][t]*(1-p[i][j])+dp[i][j-1][t-1]*p[i][j];
    	   else
    	     dp[i][j][t]=dp[i][j-1][t-1]*p[i][j];
    	 }
    
    	 double p1=1,p2;
    
    	 fre(i,1,n+1)
    	    p1*=(1-dp[i][m][0]);    //每个人都做出提的概率
    
    	 p2=1;
    
    	 fre(i,1,n+1)
    	  {
    	  	 double te=0;
    	  	 fre(j,1,k)
    	  	   te+=dp[i][m][j];
    		 p2*=te;            //每个人做出题可是没有一个做了k道题的概率
    	  }
    
    	pf("%.3lf
    ",p1-p2);
    }
    
    int main()
    {
    	int i,j;
    	while(~sfff(m,n,k),n+m+k)
    	{
    		fre(i,1,n+1)
    		   fre(j,1,m+1)
    		     scanf("%lf",&p[i][j]);
    	   solve();
    	}
        return 0;
    }
    


  • 相关阅读:
    perl -p -i -w -e
    s///|s()()i|/i|/g|U|u|L|l|Ul|split|join|匹配到hash|匹配到变量|`date`|$^I
    /^/m|/$/m||B|$&|$`|$'|变量捕获|()?|(?:pattern)|(?<LABEL>PATTERN)|$+{LABEL}|(|)|g{LABEL}
    ALG 4-3: Optimal Caching
    ALG 4-2: Scheduling to Minimize Lateness
    ALG 4-1: Interval Scheduling
    ALG 3-n: Practice
    ALG 3-6: Directed Acyclic Graphs and Topological Ordering (有向无环图与拓扑排序)
    ALG 3-5: Connectivity in Directed Graphs (有向图的连接性)
    ALG 3-4: Testing Bipartiteness
  • 原文地址:https://www.cnblogs.com/brucemengbm/p/6916584.html
Copyright © 2011-2022 走看看