zoukankan      html  css  js  c++  java
  • 威佐夫博弈

    学习:https://blog.csdn.net/angle555945/article/details/7417722

    题目链接:https://vjudge.net/contest/231317#status/1751151850/E/0/

    有两堆石子,数量任意,可以不同。游戏开始由两个人轮流取石子。游戏规定,每次有两种不同的取法,一是可以在任意的一堆中取走任意多的石子;二是可以在两堆中同时取走相同数量的石子。最后把石子全部取完者为胜者。现在给出初始的两堆石子的数目,如果轮到你先取,假设双方都采取最好的策略,问最后你是胜者还是败者。
    Input
    输入包含若干行,表示若干种石子的初始情况,其中每一行包含两个非负整数a和b,表示两堆石子的数目,a和b都不大于1,000,000,000。
    Output
    输出对应也有若干行,每行包含一个数字1或0,如果最后你是胜者,则为1,反之,则为0。
    Sample Input
    2 1
    8 4
    4 7
    Sample Output
    0
    1
    0

    直接看代码吧,我也说不清思路
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<stdio.h>
    #include<string.h>
    #include<cmath>
    #include<math.h>
    #include<algorithm>
    #include<set>
    #include<queue>
    typedef long long ll;
    using namespace std;
    const ll mod=1e9+7;
    const int maxn=1e5+10;
    const ll maxa=32050;
    const double x=(1.0+sqrt(5.0))/2;//注意sqrt只能用与double 和float类型的数,不能用于整形,否则要强制性类型转化
    #define INF 0x3f3f3f3f3f3f
    int main()
    {
        ll a,b;
        while(cin>>a>>b)
        {
            if(a>b)
                swap(a,b);
            int k=b-a;
            if(a==(int)(k*x))
                cout<<"0"<<endl;
            else
                cout<<"1"<<endl;
        }
        return 0;
    }
    当初的梦想实现了吗,事到如今只好放弃吗~
  • 相关阅读:
    android.permission
    Android 记住密码和自动登录界面的实现(SharedPreferences 的用法)
    人要怎样活在现实生活中
    viewpager---01
    Android ViewPager多页面滑动切换以及动画效果
    【205】C#实现远程桌面访问
    【204】显示3D大球球
    【203】利用UltraISO制作和刻录光盘映像的方法
    【202】ThinkPad手势&快捷键
    【201】SeaDAS代码
  • 原文地址:https://www.cnblogs.com/caijiaming/p/9336273.html
Copyright © 2011-2022 走看看