zoukankan      html  css  js  c++  java
  • PAT 甲级 1032 Sharing (25 分)(结构体模拟链表,结构体的赋值是深拷贝)

    1032 Sharing (25 分)
     

    To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

    fig.jpg

    Figure 1

    You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −.

    Then N lines follow, each describes a node in the format:

    Address Data Next
    

    whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

    Output Specification:

    For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

    Sample Input 1:

    11111 22222 9
    67890 i 00002
    00010 a 12345
    00003 g -1
    12345 D 67890
    00002 n 00003
    22222 B 23456
    11111 L 00001
    23456 e 67890
    00001 o 00010
    

    Sample Output 1:

    67890
    

    Sample Input 2:

    00001 00002 4
    00001 a 10001
    10001 s -1
    00002 a 10002
    10002 t -1
    

    Sample Output 2:

    -1

    题意:

    求两个链表的首个共同结点的地址。如果没有,就输出-1

    错误点:

    1.第一次测试点3超时,原因可能是在遍历时,多次出现a[i].v,a[i].nxt,a[i]出现的次数多了那么遍历a的次数也多了,可能会超时。

    2.结构体赋值时深度拷贝,要注意!!!深拷贝是将对象及值复制过来,两个对象修改其中任意的值另一个值不会改变。

    #include<bits/stdc++.h>
    using namespace std;
    struct node{
        int v;
    }a[100005];
    int main()
    {
        a[1].v=520;
        node t=a[1];
        t.v=1314;
        cout<<"a[1].v "<<a[1].v<<endl; 
        cout<<"t.v "<<t.v<<endl; 
        return 0;
    }
    
    结果:
    a[1].v 520
    t.v 1314

    AC代码:

    #include<bits/stdc++.h>
    using namespace std;
    struct node{
        char k;
        int nxt;
        int v;
    }a[100005];
    int main()
    {
        int head1,head2,n;
        cin>>head1>>head2>>n;
        int x,y;char s;
        for(int i=1;i<=n;i++){    
            cin>>x>>s>>y;
            a[x].k=s;
            a[x].nxt=y;
            a[x].v=0;
        }
        int f=-1;
        for(int i=head1;i!=-1;i=a[i].nxt){
            a[i].v=1;
        }
        for(int i=head2;i!=-1;i=a[i].nxt){
            if(a[i].v==1){
                f=i;
                break;
            }
        }
        if(f==-1){
            cout<<f;
        }else{
            printf("%05d",f);
        }
        return 0;
    }
  • 相关阅读:
    【随手记录】PG数值类型记录
    【SkyWalking】 Can't find service by service instance id from cache, service instance id is:xxx
    【随手记录】定时邮件发送限制 SMTPSendFailedException:557
    【随手记录】IDEA一个工程打开多个项目
    【随手记录】时间格式转换报错:while it seems to fit format 'yyyy-MM-dd'T'HH:mm:ss.SSSZ'
    【随手记录】实体类里方法自动执行问题
    【随手记录】IDEA的工具mode切换
    【随手记录】MagicNumber 魔数 在协议里作用
    js singleton
    js 对象的深层嵌套函数对对象属性的访问
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/11399779.html
Copyright © 2011-2022 走看看