zoukankan      html  css  js  c++  java
  • PAT 甲级 1039 Course List for Student (25 分)(字符串哈希,优先队列,没想到是哈希)*

    1039 Course List for Student (25 分)
     

    Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤), the number of students who look for their course lists, and K (≤), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni​​ (≤) are given in a line. Then in the next line, Ni​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

    Output Specification:

    For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

    Sample Input:

    11 5
    4 7
    BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
    1 4
    ANN0 BOB5 JAY9 LOR6
    2 7
    ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
    3 1
    BOB5
    5 9
    AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
    ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
    

    Sample Output:

    ZOE1 2 4 5
    ANN0 3 1 2 5
    BOB5 5 1 2 3 4 5
    JOE4 1 2
    JAY9 4 1 2 4 5
    FRA8 3 2 4 5
    DON2 2 4 5
    AMY7 1 5
    KAT3 3 2 4 5
    LOR6 4 1 2 4 5
    NON9 0
    
    作者: CHEN, Yue
    单位: 浙江大学
    时间限制: 600 ms
    内存限制: 64 MB

    题意:

      浙江大学有40000名在校生,2500门课,给一张课程登记表,上面有K个课程,每门课分别有Ni个学生选,通过这张选课登记表统计出每个学生的申报的课程,分别有N个学生要查询他们的选课信息。其中,课程编号0~K-1,学生编号用3个大写英语字母和1个数字进行编号。

    题解:

      直接用map最后一个测试内存超限:23/25,一开始数组内存超限,改用优先队列还是超限,实在无奈查题解,原来要用字符串哈希。在非常大的数据下的确是需要严谨的哈希算法。没学过字符串哈希,第一次,要记住了。这题用map来实现学生姓名和学生编号之间的映射会超时,因此需要用字符串hash求解。读取每门课的所有选课学生,然后将该课程编号加到所有选了这门课的学生里面。

    int getID(char name[]) {
        int id = 0;
        for(int i = 0; i < 3; i++) {
            id = id * 26 + (name[i] - 'A');
        }
        id = id * 10 + (name[3] - '0');
        return id;
    }

      我们这里考虑使用哈希表,麻烦的是,学生的名称是英文字母+数字的组合,无法直接作为数组的索引。但好在学生的名称是有规律的,3位英文字母可以看作一个26进制数,最后一位是10进制,这种进制混编方式能够保证每一个学生都有一个唯一的id。我们根据根据这种思路把char*类型的name转换成int型的id,然后这个id就可以作为每个学生唯一的标识。
      申请26 * 26 * 26 * 10个vector(而不是40000个,转换空间需要),id作为学生的查找索引,那么每个vector便变成了学生的课程记录,直接排序即可。

    AC代码:

    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<queue>
    #include<map>
    #include<string>
    #include<cstring>
    using namespace std;
    #define MAX_STUDENT 26*26*26*10
    struct cmp
    {
        bool operator()(int x,int y)
        {
            return x>y;
        }
    };
    priority_queue<int,vector<int>,cmp>q[MAX_STUDENT];
    int getID(char name[]) {
        int id = 0;
        for(int i = 0; i < 3; i++) {
            id = id * 26 + (name[i] - 'A');
        }
        id = id * 10 + (name[3] - '0');
        return id;
    }
    int n,m;
    char name[6];
    int k;
    int main()
    {
        cin>>n>>m;
        for(int i=1;i<=m;i++){
            int cla,num;
            cin>>cla>>num;
            for(int j=1;j<=num;j++){        
                cin>>name;
                k=getID(name);
                q[k].push(cla);
            }
        }
        for(int i=1;i<=n;i++){
            cin>>name;
            k=getID(name);
            cout<<name<<" "<<q[k].size();
            while(!q[k].empty()){
                cout<<" "<<q[k].top();
                q[k].pop();
            }
            cout<<endl;
        }
        return 0;
     } 
  • 相关阅读:
    工作总结_JS_1
    工作总结_js
    图片上传_及时显示
    js_截取Url值
    工作总结_sql
    Django项目配置xadmin 无法加载主题切换功能
    pip安装库慢问题解决方法
    Python模块Scrapy导入出错:ImportError: cannot import name xmlrpc_client
    python读取文件解码失败
    pycharm 修改新建文件时的头部模板
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/11436263.html
Copyright © 2011-2022 走看看