zoukankan      html  css  js  c++  java
  • PAT 甲级 1042 Shuffling Machine (20 分)(简单题)

    1042 Shuffling Machine (20 分)
     

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, ..., S13, 
    H1, H2, ..., H13, 
    C1, C2, ..., C13, 
    D1, D2, ..., D13, 
    J1, J2
    

    where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer K (≤) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
    

    Sample Output:

    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

    题意:

    有54张牌,编号为1~54,初始按编号从小到大排列。这些牌按初始排列给定花色,从左到右为13张S,13张H,13张C,13张D,2张J,接下来执行一操作,将牌的位置改变为指定位置,这样的操作执行k次。求最好的排列结果。

    题解:

    可以开两个数组,a与b分别用来存放每次执行操作前的牌序和执行操作后的牌序。

    AC代码:

    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<queue>
    #include<map>
    #include<string>
    #include<cstring>
    using namespace std;
    string a[60];
    string b[60];
    int n;
    int change[60];
    int main()
    {
        cin>>n;
        for(int i=1;i<=4;i++){
            for(int j=1;j<=13;j++){
                string c;
                if(i==1) c='S';
                else if(i==2) c='H';
                else if(i==3) c='C';
                else if(i==4) c='D';
                char c2;
                string s;
                s=s+c;
                if(j<10){
                    c2=j+'0';
                    s+=c2;    
                }else{
                    c2=1+'0';
                    s+=c2;
                    c2=j-10+'0';
                    s+=c2;
                }
                a[(i-1)*13+j]=s;
            }
        }
        a[53]="J1";
        a[54]="J2";
        /*for(int i=1;i<=54;i++){
            cout<<a[i]<<" ";
        }*/
        for(int i=1;i<=54;i++) cin>>change[i];
        while(n--){
            for(int i=1;i<=54;i++)
            {
                b[change[i]]=a[i];
            }
            for(int i=1;i<=54;i++)
            {
                a[i]=b[i];
            }
        }
        for(int i=1;i<=54;i++)
        {
            cout<<a[i];
            if(i!=54){
                cout<<" ";
            }
        }
        return 0;
    }
  • 相关阅读:
    java中的注解
    jQuery中的pushStack
    jenkins+maven+svn构建项目,及远程部署war包到tomcat上
    mysql中的find_in_set的使用
    svn的使用总结
    poi导出excel,以字符串格式输出数字
    eclipse中在整个工程中查找一个字符串的步骤
    Android Service学习
    Android生成签名文件
    开源移动医疗应用框架:mHealhDroid及APP
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/11438604.html
Copyright © 2011-2022 走看看