zoukankan      html  css  js  c++  java
  • PAT 甲级 1072 Gas Station (30 分)(dijstra)

    1072 Gas Station (30 分)
     

    A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

    Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤), the total number of houses; M (≤), the total number of the candidate locations for the gas stations; K (≤), the number of roads connecting the houses and the gas stations; and DS​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

    Then K lines follow, each describes a road in the format

    P1 P2 Dist
    

    where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

    Output Specification:

    For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

    Sample Input 1:

    4 3 11 5
    1 2 2
    1 4 2
    1 G1 4
    1 G2 3
    2 3 2
    2 G2 1
    3 4 2
    3 G3 2
    4 G1 3
    G2 G1 1
    G3 G2 2
    

    Sample Output 1:

    G1
    2.0 3.3
    

    Sample Input 2:

    2 1 2 10
    1 G1 9
    2 G1 20
    

    Sample Output 2:

    No Solution
    
    作者: CHEN, Yue
    单位: 浙江大学
    时间限制: 200 ms
    内存限制: 64 MB

    题意:

    给出一个图,其中有 N <= 103 个节点是居民房,M
    <= 10 个节点是计划建造加油站的候选点。给出加油站所能服务的最远距离 D。要求计算出合适的位置建造加油站,满足如下优先级条件:

    1.所有居民房必须在加油站的服务距离内。

    2.所有居民房中距离加油站的最近的居民房与加油站之间的距离是最远的。(大概是安全方面的考虑,加油站要离居民区远一点)

    3.所有房间距离加油站的最小距离的总和最小。(节约居民加油的总体成本)

    4.同等条件下,序号越小的加油站优先。

    题解:

    实际上是求加油站到所有点的最短路径的问题,使用 Dijsktra 可以满足。

    另外,需要考虑求最短路径的过程中是否要将其他加油站所构建的路径算入在内

    思路我很快想到了,但是写的不够熟练,粗心挑了挺久的bug,后来最后的一个测试点没过,原因是输入的时候我用的的char,没有考虑两位数三位数,像G13,2000这种。

    AC代码:

    #include<iostream>
    #include<algorithm>
    #include<string>
    #include<cstring>
    #define inf 0x3f3f3f3f
    using namespace std;
    int e[1025][1025];
    int dis[15][1025];//dijstra
    int v[1025];
    int n,m,k,ds;
    string p;
    struct node{
        int id;
        int mi;
        int sum;
    }ans[20];
    bool cmp(node x,node y){
        if(x.mi==y.mi){
            if(x.sum==y.sum){
                return x.id<y.id;
            }
            return x.sum<y.sum;
        }
        return x.mi>y.mi;
    }
    void dijstra(int s){
        for(int i=1;i<=n+m;i++){
            dis[s][i]=e[i][s+n];
        }
        memset(v,0,sizeof(v));
        v[s+n]=1;
        int kk=-1;
        int mm=inf;
        for(int i=1;i<=n+m;i++){
            kk=-1;
            mm=inf;
            for(int j=1;j<=n+m;j++){
                if(!v[j]&&dis[s][j]<mm){
                    mm=dis[s][j];
                    kk=j;
                }
            }
            if(kk==-1) break;
            v[kk]=1;
            for(int j=1;j<=n+m;j++){
                if(v[j]!=1&&dis[s][j]>dis[s][kk]+e[kk][j]){
                    dis[s][j]=dis[s][kk]+e[kk][j];
                }
            }
        }
    }
    int main(){
        cin>>n>>m>>k>>ds;
        for(int i=1;i<=n+m;i++){
            for(int j=1;j<=n+m;j++){
                e[i][j]=inf;
                if(i==j) e[i][j]=0;
            }
        }
        for(int i=1;i<=k;i++){
            int u=0,v=0,dd;
            cin>>p;//输入不能用char,可能会出现G11,199这样的数字
            if(p[0]=='G'){
                for(int j=1;j<p.length();j++){
                    u=u*10+p[j]-'0';
                }
                u+=n;
            }else{
                for(int j=0;j<p.length();j++){
                    u=u*10+p[j]-'0';
                }
            }
            cin>>p;
            if(p[0]=='G'){
                for(int j=1;j<p.length();j++){
                    v=v*10+p[j]-'0';
                }
                v+=n;
            }else{
                for(int j=0;j<p.length();j++){
                    v=v*10+p[j]-'0';
                }
            }
            cin>>dd;
            if(dd<e[u][v]){
                e[u][v]=e[v][u]=dd;
            }
        }
        int num=0;//记录备选答案的个数
        int f;//标记是否超出范围
        for(int i=1;i<=m;i++){
            dijstra(i);
            int min_d=inf;//最小距离
            int sum_d=0;//距离和
            f=1;
            for(int j=1;j<=n;j++){
                if(dis[i][j]>ds){//超出范围不放入ans
                    f=0;
                    break;
                }
                if(min_d>dis[i][j]){
                    min_d=dis[i][j];
                }
                sum_d+=dis[i][j];
            }
            if(f){
                ans[++num].id=i;
                ans[num].mi=min_d;
                ans[num].sum=sum_d;
            }
        }
        if(num==0) cout<<"No Solution";
        else{
            sort(ans+1,ans+1+num,cmp);
            cout<<"G"<<ans[1].id<<endl;
            printf("%.1f %.1f",ans[1].mi*1.0,ans[1].sum*1.0/n);
        }
        return 0;
    }
    
    
        
  • 相关阅读:
    ASP.NET Core 2.1 Web API + Identity Server 4 + Angular 6 + Angular Material 实战小项目视频
    .NET Core TDD 前传: 编写易于测试的代码 -- 单一职责
    学习Identity Server 4的预备知识 (误删, 重补)
    .NET Core TDD 前传: 编写易于测试的代码 -- 全局状态
    .NET Core TDD 前传: 编写易于测试的代码 -- 依赖项
    .NET Core TDD 前传: 编写易于测试的代码 -- 构建对象
    .NET Core TDD 前传: 编写易于测试的代码 -- 缝
    SpringBoot入门教程(十)应用监控Actuator
    SpringBoot入门教程(九)定时任务Schedule
    SpringBoot入门教程(八)配置logback日志
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13270606.html
Copyright © 2011-2022 走看看