zoukankan      html  css  js  c++  java
  • PAT 甲级 1035 Password (20 分)(简单题)

    1035 Password (20 分)
     

    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (≤), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    

    Sample Output 1:

    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    

    Sample Input 2:

    1
    team110 abcdefg332
    

    Sample Output 2:

    There is 1 account and no account is modified
    

    Sample Input 3:

    2
    team110 abcdefg222
    team220 abcdefg333
    

    Sample Output 3:

    There are 2 accounts and no account is modified

    题解:

    题目大意: 给你N个用户名和密码,要求把1转换成@,0 转换成%,l(L的小写)转换成L,O转换成o。
    解题思路: 没啥弯弯绕绕的,直接挨个判断就行了,注意最后的输出就好 。

    AC代码:

    #include<bits/stdc++.h>
    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<queue>
    #include<map>
    #include<string>
    #include<cstring>
    using namespace std;
    using namespace std;
    struct node{
        string nm;
        char s[3005];
    }a[1005];
    int n;
    int main(){
        string nm;
        char p[3005];
        cin>>n;
        int f=0;
        int k=0;
        for(int i=1;i<=n;i++){
            cin>>nm>>p;
            int l=strlen(p);
            f=0;
            for(int j=0;j<l;j++){
                if(p[j]=='1'){
                    f=1;
                    p[j]='@';
                }
                if(p[j]=='0'){
                    f=1;
                    p[j]='%';
                }
                if(p[j]=='l'){
                    f=1;
                    p[j]='L';
                }
                if(p[j]=='O'){
                    f=1;
                    p[j]='o';
                }
            }
            if(f){
                a[++k].nm=nm;
                for(int j=0;j<l;j++){
                    a[k].s[j]=p[j];
                }
            } 
        }
        if(!f&&n==1){
            cout<<"There is 1 account and no account is modified";
        }else if(!f){
            cout<<"There are "<<n<<" accounts and no account is modified";
        }else{
            cout<<k<<endl;
            for(int i=1;i<=k;i++){
                cout<<a[i].nm<<" "<<a[i].s<<endl;
            }
        }
        return 0;
    } 
  • 相关阅读:
    在不是modelAttribute的情况下,如何保存页面输入值的方法(多行遍历)
    关于Hibernate中No row with the given identifier exists问题的原因及解决
    Oracle中exit,return,continue
    如何将表的行数赋值给变量(MySQL)
    论MySQL中如何代替Oracle中select into new_table from old_table
    有关linux下redis overcommit_memory的问题,有需要的朋友可以参考下。
    CentOS 6.6 中 mysql_5.6 主从数据库配置
    CentOS 6.6 中jdk1.6的安装和配置方法
    解决 Amoeba连接mysql出错 解决方案
    Linux系统memcached安装
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13270658.html
Copyright © 2011-2022 走看看