zoukankan      html  css  js  c++  java
  • HDU 1045 Fire Net

    Fire Net

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 246   Accepted Submission(s) : 143

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

    Input

    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

    Output

    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

    Sample Input

    4
    .X..
    ....
    XX..
    ....
    2
    XX
    .X
    3
    .X.
    X.X
    .X.
    3
    ...
    .XX
    .XX
    4
    ....
    ....
    ....
    ....
    0
    

    Sample Output

    5
    1
    5
    2
    4
    

    #include <iostream>
    using namespace std;
    char map[110][110];
    int v[110][110];
    int cmax = 0;
    int i, j, n;
    int safe(int ti, int tj)
    {
        int c;
        for (c = tj; c >= 1; c--)//上面探测安不安全
        {
            if (map[ti][c] == 'o') return 0;
            if (map[ti][c] == 'X') break;
        }
        for (c = tj; c <= n; c++)//向下探测
        {
            if (map[ti][c] == 'o') return 0;
            if (map[ti][c] == 'X') break;
        }
        for (c = ti; c >= 1; c--)
        {
            if (map[c][tj] == 'o') return 0;
            if (map[c][tj] == 'X') break;
        }
        for (c = ti; c <= n; c++)
        {
            if (map[c][tj] == 'o') return 0;
            if (map[c][tj] == 'X') break;
        }
        return 1;
    }
    int cc;//用来计数造多少
    void dfs(int x, int y)
    {
        int i, j;//太关键了
        for (i = 1; i <= n; i++)
        {
            for (j = 1; j <= n; j++)
            {
                if (map[i][j] == 'X' || map[i][j] == 'o') continue;
                if (safe(i, j) == 0) continue;
                map[i][j] = 'o'; cc++;
                dfs(i, j);
                if (cc>cmax) cmax = cc;
                map[i][j] = '.';
                cc--;//回退
    
            }
        }
    }
    int main()
    {
    
        while (cin >> n)
        {
            if (n == 0) return 0;
            cmax = 0; cc = 0;
            int a, b;
            for (a = 1; a <= n; a++)
            {
                for (b = 1; b <= n; b++)
                {
                    cin >> map[a][b];
                }
            }
            dfs(1, 1);
            cout << cmax << endl;
        }
        return 0;
    }


  • 相关阅读:
    Duilib 源码分析(二)消息处理
    Duilib 源码分析(一)示例推演
    2021 Duilib最新入门教程(七)Duilib处理消息
    2021 Duilib最新入门教程(六)Duilib界面设计
    2021 Duilib最新入门教程(五)Duilib调用静态库示例
    2021 Duilib最新入门教程(四)Duilib编译静态库
    源文件(cpp)、静态库(lib)、动态库(dll)
    2021 Duilib最新入门教程(三)Duilib调用动态库示例
    supernova-SN_TV MUF简介
    jieba+pyecharts 词云图应用
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13271295.html
Copyright © 2011-2022 走看看