zoukankan      html  css  js  c++  java
  • HDU 1896 Stones

    Stones

    Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
    Total Submission(s): 3405    Accepted Submission(s): 2214


    Problem Description
    Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
    There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
     
    Input
    In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
    For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
     
    Output
    Just output one line for one test case, as described in the Description.
     
    Sample Input
    2 2 1 5 2 4 2 1 5 6 6
     
    Sample Output
    11 12
     
     
    //优先级队列
    #include <iostream>
    #include <queue>
    #include <algorithm>
    using namespace std;
    //用于优先级
    struct s
    {
        int lo;
        int dis;
        friend bool operator <(s a,s b) 
        {//位置小的先处理,位置相同,扔的近的先处理(近的扔出去就是偶数,远的还有机会再扔)
            if(a.lo==b.lo)
            return a.dis>b.dis;
            return a.lo>b.lo;
        }
    }d;
    
    int main()
    {
        priority_queue<s>q;
        int t,max;
        int n,i;
        cin>>t;
        while(t--)
        {
            cin>>n;
            for(i=1;i<=n;i++)
            {
                cin>>d.lo>>d.dis;
                q.push(d);
            }
            int num=1;
            while(!q.empty())
            {
                d=q.top();//=q.front();
                q.pop();
                if(num%2==1)
                {
                    d.lo=d.lo+d.dis;
                    max=d.lo;
                    q.push(d);
                }
                num++;
            }
            cout<<max<<endl;
        }
        return 0;
    }
  • 相关阅读:
    数组子数组求最大值1
    乐游 游戏论坛开发第二阶段
    软件开发第一天
    团队开发
    解决libpython2.6.so.1.0: cannot open shared object file
    linux卸载Python3
    在Linux上安装Python3.7.1
    Pytest高级进阶之Fixture
    发现使用id定位元操作不了
    报错:Original error: Could not proxy command to remote server. Original error: Error: read ECONNRESET
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/8411131.html
Copyright © 2011-2022 走看看