zoukankan      html  css  js  c++  java
  • PTA 1004 Counting Leaves (30)(30 分)(dfs或者bfs)

    1004 Counting Leaves (30)(30 分)

    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

    Input

    Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    Output

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

    Sample Input

    2 1
    01 1 02

    Sample Output

    0 1

    1004.计算叶子个数

    一个家庭的层级结构经常被表现为一个家谱树。你的任务是统计这些家庭成员中谁没有孩子。

    输入

    每个输入文件包含一个测试实例。每个实例开始的一行包含N和M,N指树中的结点个数(0<N<100),M指非叶结点的个数。然后下面有M行,每行的格式如下:

    ID K ID[1] ID[2] ...ID[K]

    ID是一个两位数的数字,表示一个非叶结点。K表示其孩子的数量。随后是一个序列,序列中是该结点的孩子结点的两位数ID。为了简单起见,我们把根结点的ID固定为01。

    输出

    对于每个测试实例,你应该计算从根结点开始的每一层中没有孩子的家庭成员的个数。数字必须在一行内输出,用空格分隔,在每行结尾不能有多余的空格。

    测试样例表示了一个只有两个结点的树,01是根结点,02是它仅有的孩子。因此在根结点01层级,没有叶节点。再下一层级,有一个叶结点。然后我们应该在一行内输出“0 1”。

    我用dfs建的树,要注意特殊情况:

    0 0 是0

    1 0是1

    dfs的第4个测试点一直段错误(27/30),求各位大佬帮助,bfs第4个也一直段错误,第2个答案错误(19/30),晕死

    2 1
    01 1 02
    
    
    2 2
    01 2 02 03
    02 2 04 05
    
    3 3
    01 3 02 05 06
    02 1 03
    05 2 04 07
    
    4 1
    01 2 02 03
    
    2 3
    01 2 02 03
    02 2 04 05
    05 2 06 07
    
    0 0
    #include<iostream>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<cmath>
    #include<queue>
    #include<map>
    #define inf 0x3f3f3f3f
    using namespace std;
    queue<int>q[11000];
    int a[1000005];
    int rec[1005];
    int n,m;
    void build(int root,int k)
    {
        int count=1;
        while(!q[k].empty())
        {
            int x=q[k].front();
            q[k].pop();
            a[n*root+rec[count]]=x;
            if(!q[x].empty())
            {
                build(n*root+rec[count],x);
            }
            count++;
        }
    }
    
    int main()
    {
        cin>>n>>m;
        for(int i=2;i<=n+1;i++)
        {
            rec[i-1]=i-n;
        }
        memset(a,0,sizeof(a));
        if(n==0) 
            cout<<0;
        else if(m==0)
            cout<<1;
        for(int i=1;i<=m;i++)
        {
            int x;
            cin>>x;
            int nn;
            cin>>nn;
            for(int j=1;j<=nn;j++)
            {
                int y;
                cin>>y;
                q[x].push(y);
            }
        }
        a[1]=1;
        build(1,1);
        int st=1,en=1;
        for(int i=1;i<=m*n;i++)
        {
            int sum=0;
            bool f=0;
            for(int j=st;j<=st+en-1;j++)
            {
                if(a[j]!=0&&a[n*j+rec[1]]==0)
                    sum++;
                if(a[j]!=0)
                    f=1;
            }
            if(f==0) break;
            if(st==1)
            {
                cout<<sum;
            }
            else
            {
                cout<<" "<<sum;
            }
            st=st+en;
            en=en*n;
        }
        return 0;
    }
    View Code

    bfs代码AC代码

    #include<iostream>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<cmath>
    #include<queue>
    #include<map>
    #include<vector>
    #define inf 0x3f3f3f3f
    using namespace std;
    int n,m;
    vector<int>v[105];
    queue<int>q;
    int main()
    {
        cin>>n>>m;
        for(int i=1;i<=m;i++)
        {
            int x;
            cin>>x;
            int num;
            cin>>num;
            for(int j=1;j<=num;j++)
            {
                int y;
                cin>>y;
                v[x].push_back(y);
            }
        }
        q.push(1);
        if(m==0)
            cout<<1;
        else if(n==0)
            cout<<0;
        else
        {
            if(v[1].size()==0)
            {
                cout<<1;
            }
            else
                cout<<0;
            int k=1;
            int kk=0;
            int nn=0;
            int count=0;
            while(!q.empty())
            {
                if(nn==k)
                {
                    cout<<" "<<count;
                    count=0;
                    nn=0;
                    k=kk;
                    kk=0;
                }
                nn++;
                int x=q.front();
                q.pop();
                for(int j=0;j<v[x].size();j++)
                {
                    int y=v[x].at(j);
                    if(v[y].size()==0)
                        count++;
                    else
                    {
                        q.push(y);
                        kk++;
                    }
    
                }
            }
            cout<<" "<<count;
        }
        return 0;
    }
     
  • 相关阅读:
    jquery 回车切换 tab功能
    Jtemplates 基本语法
    Rdlc报表出现空白页解决方法
    动软代码生成与 EntityFramework 实体生成模板
    windows 无法启动asp.net 状态服务 错误 0x8007277a
    导出Excel Gridview
    错误提示:类型“GridView”的控件“GridView1”必须放在具有 runat=server 的窗体标记内 .
    c#与vb.net在App_Code里面编译要通过,需要以下web.config的配置
    個人最近做的最多的重複工作就是excel导出
    Js/Jquery获取iframe中的元素 在Iframe中获取父窗体的元素方法
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/9443618.html
Copyright © 2011-2022 走看看