zoukankan      html  css  js  c++  java
  • HDU-4927 Series 1

    http://acm.hdu.edu.cn/showproblem.php?pid=4927

    同学用java写的大整数相减

    Series 1

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 295    Accepted Submission(s): 100

    Problem Description
    Let A be an integral series {A1, A2, . . . , An}.
    The zero-order series of A is A itself.
    The first-order series of A is {B1, B2, . . . , Bn-1},where Bi = Ai+1 - Ai.
    The ith-order series of A is the first-order series of its (i - 1)th-order series (2<=i<=n - 1).
    Obviously, the (n - 1)th-order series of A is a single integer. Given A, figure out that integer.
     
    Input
    The input consists of several test cases. The first line of input gives the number of test cases T (T<=10).
    For each test case: The first line contains a single integer n(1<=n<=3000), which denotes the length of series A. The second line consists of n integers, describing A1, A2, . . . , An. (0<=Ai<=105)
     
    Output
    For each test case, output the required integer in a line.
     
    Sample Input
    2
    3
    1 2 3
    4
    1 5 7 2
     
    Sample Output
    0
    -5
    import java.math.BigInteger;
    import java.util.*;
    import java.io.*;
    
    public class Main {
    
        public static void main(String args[]) {
            Scanner in = new Scanner(System.in);
            int t = in.nextInt();
            int a[] = new int[3005];
            for (int cas = 1; cas <= t; cas++) {
                int n = in.nextInt();
                int  i, j;
                for (i = 1; i <= n; ++i) {
                    a[i] = in.nextInt();
                }
                BigInteger ans = BigInteger.valueOf(a[n]);
                BigInteger x = BigInteger.valueOf(1);
                BigInteger flag = BigInteger.valueOf(-1);
                n = n -1;
                for(i=1,j=n; i<=n; i++,j--)
                {
                    x = x.multiply(BigInteger.valueOf(j)).divide(BigInteger.valueOf(i));
                    x = x.multiply(flag);
                    ans = ans.add(x.multiply(BigInteger.valueOf(a[j])));
                }
                System.out.println(ans);
            }
        }
    }
     
  • 相关阅读:
    (兼容IE8)的渐变
    左侧固定,右侧自适应,两列等高并且自适应的第二种办法
    左侧定宽,右侧自适应,两列布局且等高
    下拉框重写
    在页面中输出当前客户端时间
    用哈希表去数组重复项,有详细注释
    求数组最大值、求和、乘法表、取整
    类似新浪微博输入字符计数的效果
    将博客搬至CSDN
    Mysql常用操作
  • 原文地址:https://www.cnblogs.com/cancangood/p/3897912.html
Copyright © 2011-2022 走看看