zoukankan      html  css  js  c++  java
  • POJ 2185 Milking Grid [KMP]

    Milking Grid
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 8226   Accepted: 3549

    Description

    Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns. 

    Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below. 

    Input

    * Line 1: Two space-separated integers: R and C 

    * Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character. 

    Output

    * Line 1: The area of the smallest unit from which the grid is formed 

    Sample Input

    2 5
    ABABA
    ABABA
    

    Sample Output

    2
    

    Hint

    The entire milking grid can be constructed from repetitions of the pattern 'AB'.

    Source


    题意:在N*M字符矩阵中找出一个最小子矩阵,使其多次复制所得的矩阵包含原矩阵。N<=10000,M<=75


    只需要一行做一个字母求一次,再一列做一个字母求一次就好了,然后和子串是一样的n-fail[n]

    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cmath>
    using namespace std;
    typedef long long ll;
    const int N=1e4+5,M=80;
    int n,m,k,fail[N];
    char s[N][M];
    bool cmp1(int a,int b){
        for(int i=1;i<=m;i++) if(s[a][i]!=s[b][i]) return false;
        return true;
    }
    bool cmp2(int a,int b){
        for(int i=1;i<=k;i++) if(s[i][a]!=s[i][b]) return false;
        return true;
    }
    void getFail(int n,bool (*cmp)(int a,int b)){
        fail[1]=0;
        for(int i=2;i<=n;i++){
            int j=fail[i-1];
            while(j&&!cmp(j+1,i)) j=fail[j];
            fail[i]=cmp(j+1,i)?j+1:0;
        }
    }
    
    int main(){
    //    freopen("in.txt","r",stdin);
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) scanf("%s",s[i]+1);
        getFail(n,cmp1);
        k=n-fail[n];
        memset(fail,0,sizeof(fail));
        getFail(m,cmp2);
        printf("%d",k*(m-fail[m]));
    }
     
  • 相关阅读:
    jQuery及javascript DOM创建节点(三)
    jQueryEasyUI Window的基本使用
    3.1、值类型
    手动依赖注入(二)
    3.1.2、字符类型
    不错不错
    我们应该讨论什么? 就面向对象的讨论所引发的一些思考
    保存个地址, 顺便问个问题~
    嗯嗯, 今天很高兴
    方法级AOP: 又一个补丁
  • 原文地址:https://www.cnblogs.com/candy99/p/6366145.html
Copyright © 2011-2022 走看看