zoukankan      html  css  js  c++  java
  • 洛谷 P3128 [USACO15DEC]最大流Max Flow

    P3128 [USACO15DEC]最大流Max Flow

    题目描述

    Farmer John has installed a new system of N-1N1 pipes to transport milk between the NN stalls in his barn (2 leq N leq 50,0002N50,000), conveniently numbered 1 ldots N1N. Each pipe connects a pair of stalls, and all stalls are connected to each-other via paths of pipes.

    FJ is pumping milk between KK pairs of stalls (1 leq K leq 100,0001K100,000). For the iith such pair, you are told two stalls s_isi​​ and t_iti​​, endpoints of a path along which milk is being pumped at a unit rate. FJ is concerned that some stalls might end up overwhelmed with all the milk being pumped through them, since a stall can serve as a waypoint along many of the KK paths along which milk is being pumped. Please help him determine the maximum amount of milk being pumped through any stall. If milk is being pumped along a path from s_isi​​ to t_iti​​, then it counts as being pumped through the endpoint stalls s_isi​​ and

    t_iti​​, as well as through every stall along the path between them.

    FJ给他的牛棚的N(2≤N≤50,000)个隔间之间安装了N-1根管道,隔间编号从1到N。所有隔间都被管道连通了。

    FJ有K(1≤K≤100,000)条运输牛奶的路线,第i条路线从隔间si运输到隔间ti。一条运输路线会给它的两个端点处的隔间以及中间途径的所有隔间带来一个单位的运输压力,你需要计算压力最大的隔间的压力是多少。

    输入输出格式

    输入格式:

    The first line of the input contains NN and KK.

    The next N-1N1 lines each contain two integers xx and yy (x e yxy) describing a pipe

    between stalls xx and yy.

    The next KK lines each contain two integers ss and tt describing the endpoint

    stalls of a path through which milk is being pumped.

    输出格式:

    An integer specifying the maximum amount of milk pumped through any stall in the

    barn.

    输入输出样例

    输入样例#1:
    5 10
    3 4
    1 5
    4 2
    5 4
    5 4
    5 4
    3 5
    4 3
    4 3
    1 3
    3 5
    5 4
    1 5
    3 4

    输出样例#1:
    9
    思路:树上差分;
    水题;
    #include<vector>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 100000+15
    using namespace std;
    int n,k,tot,maxn=-1;
    int deep[MAXN*2],size[MAXN*2],top[MAXN*2],dad[MAXN*2];
    int to[MAXN*4],from[MAXN*4],net[MAXN*4],c[MAXN*4];
    void add(int u,int v){
        to[++tot]=v;net[tot]=from[u];from[u]=tot;
        to[++tot]=u;net[tot]=from[v];from[v]=tot;
    }
    void dfs(int x){
        size[x]=1;
        deep[x]=deep[dad[x]]+1;
        for(int i=from[x];i;i=net[i])
            if(dad[x]!=to[i]){
                dad[to[i]]=x;
                dfs(to[i]);
                size[x]+=size[to[i]];
            }
    }
    void dfs1(int x){
        int t=0;
        if(!top[x])    top[x]=x;
        for(int i=from[x];i;i=net[i])
            if(dad[x]!=to[i]&&size[t]<size[to[i]])
                t=to[i];
        if(t){
            top[t]=top[x];
            dfs1(t);
        } 
        for(int i=from[x];i;i=net[i])
            if(dad[x]!=to[i]&&to[i]!=t)
                dfs1(to[i]);
    }
    int lca(int x,int y){
        for(;top[x]!=top[y];){
            if(deep[top[x]]<deep[top[y]])
                swap(x,y);
            x=dad[top[x]];
        }
        if(deep[x]>deep[y])
            swap(x,y);
        return x;
    }
    void dfs2(int x){
        for(int i=from[x];i;i=net[i])
            if(dad[x]!=to[i]){
                dfs2(to[i]);
                c[x]+=c[to[i]];
            }
        maxn=max(maxn,c[x]);
    }
    int main(){
        cin>>n>>k;
        for(int i=1;i<n;i++){
            int u,v;
            cin>>u>>v;
            add(u,v);
        }
        dfs(1);
        dfs1(1);
        for(int i=1;i<=k;i++){
            int u,v;
            cin>>u>>v;
            int l=lca(u,v);
            c[u]++;c[v]++;
            c[l]--;c[dad[l]]--;
        }
        dfs2(1);
        cout<<maxn;
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    Idea快捷键
    基于LinkedHashMap实现一个基于LRU算法的缓存设计
    SpringBoot整合Mybatis
    MyBatis Generator自动生成代码
    java.sql.SQLException: The server time zone value 'Öйú±ê׼ʱ¼ä' is unrecognized or represents more
    Dubbo的异步调用
    Jackson的ObjectMapper的简单用法及语法
    mysql实例代码
    6. Z 字形变换
    13. 罗马数字转整数
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7399141.html
Copyright © 2011-2022 走看看