zoukankan      html  css  js  c++  java
  • 洛谷 P3047 [USACO12FEB]附近的牛Nearby Cows

    题目描述

    Farmer John has noticed that his cows often move between nearby fields. Taking this into account, he wants to plant enough grass in each of his fields not only for the cows situated initially in that field, but also for cows visiting from nearby fields.

    Specifically, FJ's farm consists of N fields (1 <= N <= 100,000), where some pairs of fields are connected with bi-directional trails (N-1 of them in total). FJ has designed the farm so that between any two fields i and j, there is a unique path made up of trails connecting between i and j. Field i is home to C(i) cows, although cows sometimes move to a different field by crossing up to K trails (1 <= K <= 20).

    FJ wants to plant enough grass in each field i to feed the maximum number of cows, M(i), that could possibly end up in that field -- that is, the number of cows that can potentially reach field i by following at most K trails. Given the structure of FJ's farm and the value of C(i) for each field i, please help FJ compute M(i) for every field i.

    给出一棵n个点的树,每个点上有C_i头牛,问每个点k步范围内各有多少头牛。

    输入输出格式

    输入格式:

     

    • Line 1: Two space-separated integers, N and K.

    • Lines 2..N: Each line contains two space-separated integers, i and j (1 <= i,j <= N) indicating that fields i and j are directly connected by a trail.

    • Lines N+1..2N: Line N+i contains the integer C(i). (0 <= C(i) <= 1000)

     

    输出格式:

     

    • Lines 1..N: Line i should contain the value of M(i).

     

    输入输出样例

    输入样例#1:
    6 2 
    5 1 
    3 6 
    2 4 
    2 1 
    3 2 
    1 
    2 
    3 
    4 
    5 
    6 
    
    输出样例#1:
    15 
    21 
    16 
    10 
    8 
    11 
    

    说明

    There are 6 fields, with trails connecting (5,1), (3,6), (2,4), (2,1), and (3,2). Field i has C(i) = i cows.

    Field 1 has M(1) = 15 cows within a distance of 2 trails, etc.

    思路:树形dp+容斥原理。

    错因:数组开小了。

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 100010
    using namespace std;
    int n,y,tot;
    int val[MAXN],into[MAXN],f[MAXN][21];
    int to[MAXN*2],net[MAXN*2],head[MAXN*2];
    void add(int u,int v){
        to[++tot]=v;net[tot]=head[u];head[u]=tot;
        to[++tot]=u;net[tot]=head[v];head[v]=tot;
    }
    int main(){
        //freopen("young.in","r",stdin);
        //freopen("young.out","w",stdout);
        scanf("%d%d",&n,&y);
        for(int i=1;i<n;i++){
            int u,v;
            scanf("%d%d",&u,&v);
            add(u,v);
            into[u]++;
            into[v]++;
        }
        for(int i=1;i<=n;i++)    scanf("%d",&val[i]);
        for(int i=1;i<=n;i++)    f[i][0]=val[i];
        for(int j=1;j<=y;j++)
            for(int i=1;i<=n;i++){
                for(int k=head[i];k;k=net[k])
                    f[i][j]+=f[to[k]][j-1];
                if(j>1)    f[i][j]-=(into[i]-1)*f[i][j-2];
                else f[i][1]+=f[i][0];
            }
        for(int i=1;i<=n;i++)
            cout<<f[i][y]<<endl;
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    为开源项目 go-gin-api 增加后台任务模块
    将多行数据以',' 进行分隔
    syslog中的“(CRON)信息(未安装MTA,丢弃输出)”错误,crontab定时任务失效
    为什么我不推荐大家去外包公司?
    Linux永久修改系统时间
    云数据库 Redis 暂时不支持外网访问
    Nginx中worker connections问题的解决方法 大量用户502
    入手
    nginx 之$proxy_host|$host|$http_host区别
    grpc-golang入门
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7512128.html
Copyright © 2011-2022 走看看