zoukankan      html  css  js  c++  java
  • 【最新】vue-cli 版本始终是2.9.6的处理办法,以及升级到最新的vue脚手架的办法

    问题描述

    遇到一种情况,就是使用vue --version 查看版本始终是2.9.6,安装命令是npm install @vue/cli ,按理说是最新版本,但是还是显示旧版,使用vue create 【项目名称】 提示是要卸载脚手架在安装,但是安装后还是2.9.6.有什么解决办法吗?我收集了网上各种结论后找到了对应的方法

    先说明原因

    其实导致这个原因是从vue-cli 3.0版本开始原来的npm install -g vue-cli 安装的都是旧版,最高到2.9.6,安装新版必须是新的命令npm install -g @vue/cli 这就导致了,如果我们再2.9.6版本还存在的情况下再使用npm install -g @vue/cli 命令就会同时存在两个版本,你用vue create 【项目名称】命令会先找到旧版的,就会提示你卸载旧版安装新版。

    解决办法

    这里就说下怎么解决。其实知道原因后就可以想到个办法,就是把旧版和新版都卸载了,就不会有冲突了,然后直接安装最新版本就可以了,npm uninstall -g vue-cli 卸载旧版、 npm uninstall -g @vue/cli 卸载新版
    之后安装新版,这里给大家推荐个命令 cnpm view @vue/cli versions --json

    查看下新版有哪些版本,你可以根据自己的需要安装新版。这里我选中安装4.5.13的版本
    npm install -g @vue/cli@4.5.13

    之后你就可以创建vue项目了vue create 【项目名称】

    这里手动创建一个项目

    这里使用我常规创建选项

    路由要使用 history 模式吗

    报错处理这里推荐使用标准模式


    报错处理机制,这里推荐吧自动修复选中

    错误推荐就使用生产单独文件

    这里会询问是否要记住此次配置,你下次要再创建项目就会有这次配置的模板,你根据需要选,默认是N

    开始创建项目了

  • 相关阅读:
    小小的封装了一个pie的echarts
    recent.css常用的页面初始化样式
    bootstrap表格多样式及代码
    Java内存回收机制
    栈帧
    互斥锁和条件变量
    UML类图的常见关系
    堆栈详解(数据与内存中的存储方式)
    PR消减视频中的鼠标声
    SmartPlant Review 三维视图快捷键
  • 原文地址:https://www.cnblogs.com/caominjie/p/14800702.html
Copyright © 2011-2022 走看看