zoukankan      html  css  js  c++  java
  • 完全背包

    John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money,
    somewhere in South-America, and that John was the only inheritor. John did not need that much money for the moment.
    But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire.
    The bank convinced him that a certain kind of bond was interesting for him. 
    This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year.
    The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest.
    Soon John realized that the optimal set of bonds to buy was not trivial to figure out.
    Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
    Assume the following bonds are available: 
    Value Annual
    interest
    4000
    3000
    400
    250

    With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900.
    After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050.
    This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
    Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests,
    find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

    Input

    The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
    The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
    The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
    The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond.
    The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

    Output

    For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

    Sample Input

    1
    10000 4
    2
    4000 400
    3000 250

    Sample Output

    14050
    题意:给出初始资金,还有年数,然后给出每个物品的购买价格与每年获得的利益,要求在给出的年份后所能得到的最大本利之和。
    #include<iostream>
    #include<cstring>
    using namespace std;
    int c[12],w[12];
    int dp[1000000];
    double Max(double x,double y)
    {
       if(x>y)
          return x;
        else
          return y;
    }
    int main()
    {
        int t;
        cin>>t;
        while(t--){
                memset(dp,0,sizeof(dp));
            int capital,year;
            cin>>capital>>year;
            int kind;
            cin>>kind;
            for(int i=1;i<=kind;i++){
                cin>>c[i]>>w[i];
                c[i]/=1000;
            }
            while(year--){
                int s=capital/1000;
                for(int i=1;i<=kind;i++)
                    for(int j=c[i];j<=s;j++)
                        dp[j]=max(dp[j],dp[j-c[i]]+w[i]);
                capital+=dp[s];
             }
             cout<<capital<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Apply SOA Design Patterns with WCF (1) Configuration Centralization (配置集中管理)
    NBearLite PetShop 4.0示例源码
    发布NBearLite中文版完全参考手册 + NBearLite 10分钟入门教程 + NBearLite v1.0.0.7 beta
    NBear WebTest 分享一个基于Web的UnitTest工具
    Linux的rsh配置rhost
    [SCM]源码管理 perforce label实例
    python面试题
    LinuxTips目录下的所有的子目录
    perlcgi基础
    perlcgi命令行调试
  • 原文地址:https://www.cnblogs.com/carry-2017/p/7382386.html
Copyright © 2011-2022 走看看