zoukankan      html  css  js  c++  java
  • Out of Hay POJ

    The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

    Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

    Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

    Input

    * Line 1: Two space-separated integers, N and M. 

    * Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

    Output

    * Line 1: A single integer that is the length of the longest road required to be traversed.

    Sample Input

    3 3

    1 2 23

    2 3 1000

    1 3 43

    Sample Output

    43

    Hint

    OUTPUT DETAILS: 

    In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

     

    我好久没做这类题了,一开始有点蒙,先看表格就知道prim的特点了:

    0 1 2 3 4 5
    1 inf 23 44 inf inf
    2 23 inf 100 77 inf
    3 44 100 inf inf inf
    4 inf 77 inf inf inf
    5 inf inf inf inf inf

     

    题解:最后这个注释很重要,看完注释就知道这个题是让求最小生成树里的最大边了。

          emmm根据题意这肯定是能生成一棵树的。

    AC代码:

     

    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    const int maxn=2006,inf=0x3f3f3f3f;
    int cost[maxn][maxn];
    int mincost[maxn];
    bool used[maxn];
    int n,m;
    void init()
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                cost[i][j]=inf;
            }
        }
    }
    int prim()
    {
        for(int i=1;i<=n;i++)
        {
            used[i]=false;
            mincost[i]=cost[1][i];//在这里找最小边
            //prim的特点就是利用这些表格比较找出和每个节点相连的最小边
        }
        used[1]=1;
        int res=0;
        while(1)
        {
            int v=-1;
            for(int i=1;i<=n;i++)
            {
                if(!used[i]&&(v==-1||mincost[i]<mincost[v]))
                    v=i;
            }
            if(v==-1)
                break;
            used[v]=true;
            if(res<=mincost[v])
                res=mincost[v];
            for(int i=1;i<=n;i++)//判断并且找最小边
            {
                if(!used[i]&&mincost[i]>cost[i][v])
                mincost[i]=cost[v][i];
            }
        }
        return res;
    }
    int main()
    {
        int a,b,c;
        while(cin>>n>>m)
        {
            init();
            while(m--)
            {
                cin>>a>>b>>c;
                if(cost[a][b]>c)//可以避免这种情况:1 2 23  2 1 33比较
                   cost[a][b]=cost[b][a]=c;
            }
            cout<<prim()<<endl;
        }
        return 0;
    }

     

     

    今天也是元气满满的一天!yeah!

     

  • 相关阅读:
    Myeclipse 找不到Convert to maven project选项
    myeclipse中disable maven nature
    运行Maven是报错:No goals have been specified for this build
    Maven 工程错误Failure to transfer org.codehaus.plexus:plexus-io:pom:1.0,Failure to transfer org.codehaus.plexus:plexus-archiver:jar:2.0.1
    -Dmaven.multiModuleProjectDirectory system propery is not set. Check $M2_HOME environment variable and mvn script match.
    新建web工程Jdk怎么不是自己安装的, 是自带的
    AGC024B Backfront
    AGC037C Numbers on a Circle
    如何看待现在的教育?自己以后怎么做!!!!
    当局者迷
  • 原文地址:https://www.cnblogs.com/cattree/p/7528101.html
Copyright © 2011-2022 走看看