zoukankan      html  css  js  c++  java
  • hdu3861 强连通分量缩点+二分图最最小路径覆盖

    The King’s Problem

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3471    Accepted Submission(s): 1231


    Problem Description
    In the Kingdom of Silence, the king has a new problem. There are N cities in the kingdom and there are M directional roads between the cities. That means that if there is a road from u to v, you can only go from city u to city v, but can’t go from city v to city u. In order to rule his kingdom more effectively, the king want to divide his kingdom into several states, and each city must belong to exactly one state. What’s more, for each pair of city (u, v), if there is one way to go from u to v and go from v to u, (u, v) have to belong to a same state. And the king must insure that in each state we can ether go from u to v or go from v to u between every pair of cities (u, v) without passing any city which belongs to other state.
      Now the king asks for your help, he wants to know the least number of states he have to divide the kingdom into.
     
    Input
    The first line contains a single integer T, the number of test cases. And then followed T cases.

    The first line for each case contains two integers n, m(0 < n <= 5000,0 <= m <= 100000), the number of cities and roads in the kingdom. The next m lines each contains two integers u and v (1 <= u, v <= n), indicating that there is a road going from city u to city v.
     
    Output
    The output should contain T lines. For each test case you should just output an integer which is the least number of states the king have to divide into.
     
    Sample Input
    1 3 2 1 2 1 3
     
    Sample Output
    2
     
    Source
    题意转载自http://www.cnblogs.com/kane0526/archive/2013/07/21/3203992.html

    题意:一个有向图,让你按规则划分区域,要求划分的区域数最少。

    规则如下:1、有边u到v以及有边v到u,则u,v必须划分到同一个区域内。2、一个区域内的两点至少要有一方能到达另一方。3、一个点只能划分到一个区域内。

    解题思路:根据规则1可知必然要对强连通分量进行缩点,缩点后变成了一个弱连通图。根据规则2、3可知即是要求图的最小路径覆盖。

    定义:

    最小路径覆盖:在图中找一些路径(路径数最少),使之覆盖了图中所有的顶点,且每个顶点有且仅和一条路径有关联。

    最小顶点覆盖:在图中找一些点(顶点数最少),使之覆盖了图中所有的边,每条边至少和一个顶点有关联。

    二分图:最小顶点覆盖=最大匹配数。

                最小路径覆盖=顶点数-最大匹配数。

    二分图最最小路径覆盖:https://www.cnblogs.com/justPassBy/p/5369930.html

    匈牙利算法:https://blog.csdn.net/dark_scope/article/details/8880547

    代码:

    #include<stdio.h>
    #include<vector>
    #include<stack>
    #include<string.h>
    using namespace std;
    vector<int> s[5050];//
    stack<int> st;
    int vt[5050];
    int cnt,ct;
    int low[5050],dfn[5050];
    int bl[5050],nd[5050];//例:如果是a-->b,则bl[b]=a;如果a点再经过tarjan算法后属于第i个集合,nd[a]=i;
    struct
    {
      int x,y;
    }mp[100050];
    int min(int a,int b)
    {
      if(a<=b)
      return a;
      return b;
    }
    int tarjan(int a)//tarjan算法
    {
      int i,j;
      low[a]=dfn[a]=cnt++;
      vt[a]=1;
      st.push(a);
      for(i=0;i<s[a].size();i++)
      {
        int u=s[a][i];
        if(!dfn[u])
        {
          tarjan(u);
          low[a]=min(low[a],low[u]);
        }
        else if(vt[u])
        low[a]=min(low[a],dfn[u]);
      }
      if(low[a]==dfn[a])
      {
        int x;
        ct++;
        do//为缩点作准备
        {
          x=st.top();
          vt[x]=0;
          nd[x]=ct;
          st.pop();
        }while(x!=a);
      }
      return 0;
    }
    int find(int a)//匈牙利算法
    {
      int i,j;
      for(i=0;i<s[a].size();i++)
      {
        int u=s[a][i];
        if(!vt[u])
        {
          vt[u]=1;
          if(bl[u]==0||find(bl[u]))
          {
            bl[u]=a;
            //printf("www%d %d ",bl[u],u);
            return 1;
          }
        }
      }
      return 0;
    }
    int main()
    {
      int n,m,t;
      int i,j;
      int a,b,sum;
      scanf("%d",&t);
    while(t--)
    {
      memset(dfn,0,sizeof(dfn));
      memset(vt,0,sizeof(vt));
      memset(bl,0,sizeof(bl));
      ct=0;
      cnt=1;
      scanf("%d%d",&n,&m);
      for(i=1;i<=n;i++)
      s[i].clear();
      for(i=1;i<=m;i++)
      {
        scanf("%d%d",&mp[i].x,&mp[i].y);
        s[mp[i].x].push_back(mp[i].y);
      }
      for(i=1;i<=n;i++)
      if(!dfn[i])tarjan(i);
      sum=0;
      for(i=1;i<=n;i++)
      s[i].clear();
      for(i=1;i<=m;i++)//缩点并重新制图
      {
        int u,v;
        u=nd[mp[i].x];
        v=nd[mp[i].y];
        if(u!=v)
        s[u].push_back(v);
      }
      for(i=1;i<=ct;i++)
      {
        memset(vt,0,sizeof(vt));
        if(find(i))
        sum++;
      }
      printf("%d ",ct-sum);
      }
      return 0;
    }

    例:

    6 6

    1 2

    2 3

    3 1

    4 1

    5 2

    6 3

    3

    10 11

    1 2

    2 3

    3 1

    3 4

    4 5

    5 6

    6 7

    7 5

    10 9

    9 8

    8 4

    2

  • 相关阅读:
    Large-Scale Oil Palm Tree Detection from High-Resolution Satellite Images Using Two-Stage Convolutional Neural Networks(worldview油棕树检测)
    Visual Detail Augmented Mapping for Small Aerial Target Detection(航片动态小目标检测)
    Large Kernel Matters —— Improve Semantic Segmentation by Global Convolutional Network(GCN全局卷积网络)
    Learning a Discriminative Feature Network for Semantic Segmentation(语义分割DFN,区别特征网络)
    Semantic Segmentation on Remotely Sensed Images Using an Enhanced Global Convolutional Network with Channel Attention and Domain Specific Transfer Learning
    Super-Resolution Restoration of MISR Images Using the UCL MAGiGAN System 超分辨率恢复
    python 中内存释放与函数传递numpy数组问题
    hdfs的shell命令
    副本策略
    数据分割
  • 原文地址:https://www.cnblogs.com/cglongge/p/8727967.html
Copyright © 2011-2022 走看看