zoukankan      html  css  js  c++  java
  • 1006 Sign In and Sign Out (25 分)

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time

    where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:

    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40

    Sample Output:

    SC3021234 CS301133

    Submit:

    #include <iostream>
    #include <climits>
    using namespace std;
    //目标:求最早进和最晚出的ID
    //思路:求时间(s)最小和最大,替换时间比较同时替换ID
    int main() {
        int m,i,h1,m1,s1,h2,m2,s2,max=INT_MIN,min=INT_MAX;
        scanf("%d",&m);
        string smax,smin;
        for (i=0; i<m; i++) {
            string sId;
            cin >> sId;
            scanf("%d:%d:%d %d:%d:%d",&h1,&m1,&s1,&h2,&m2,&s2);
            int tempIn = h1*3600+m1*60+s1;
                int tempOut = h2*3600+m2*60+s2;
            if (min > tempIn) {
                min = tempIn;
                smin = sId;
            }
            if (max < tempOut) {
                max = tempOut;
                smax = sId;
            }
        }
        cout << smin << " " << smax;
        return 0;
    }

    参考:

    柳婼-https://blog.csdn.net/liuchuo/article/details/54561626

    昵称五个字-https://blog.csdn.net/a617976080/article/details/89676670

  • 相关阅读:
    jQuery Mobile 总结
    妙味,结构化模块化 整站开发my100du
    详解使用icomoon生成字体图标的方法并应用
    Vue.js搭建路由报错 router.map is not a function,Cannot read property ‘component’ of undefined
    jquery 最全知识点图示
    图解Js event对象offsetX, clientX, pageX, screenX, layerX, x区别
    Oracle存储过程及函数的练习题
    SQL中IS NOT NULL与!=NULL的区别
    mysql字符集和排序规则
    一个web项目web.xml的配置中<context-param>配置作用
  • 原文地址:https://www.cnblogs.com/cgy-home/p/15115084.html
Copyright © 2011-2022 走看看