zoukankan      html  css  js  c++  java
  • 1031. Hello World for U

    1031. Hello World for U (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

    h  d
    e  l
    l  r
    lowo
    
    That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

    Input Specification:

    Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

    Output Specification:

    For each test case, print the input string in the shape of U as specified in the description.

    Sample Input:
    helloworld!
    
    Sample Output:
    h   !
    e   d
    l   l
    lowor

    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner  in=new Scanner(System.in);
            String n=in.nextLine();
            int num=n.length();
            int n1,n3,x = 0,y = 0;
            for(n3=3;n3<=num;n3++){
                for(n1=n3;n1>=0;n1--){
                    //System.out.println(n1+" "+n3+" "+(2*n1+n3-2)+" "+num);
                    if(2*n1+n3-2==num){
                        x=n1;
                        y=n3;
                        break;
                    }
                    if(x!=0&&y!=0) break;
                }
            }
            //System.out.println(num+" "+x+" "+y);
            for(int i=0,j=num-1;i<x-1;i++,j--){
                System.out.print(n.charAt(i));
                for(int k=0;k<y-2;k++)
                {
                    System.out.print(" ");
                }
                System.out.println(n.charAt(j));
            }
            for(int i=x-1;i<x-1+y;i++){
                System.out.print(n.charAt(i));
            }
        }
    
    }
  • 相关阅读:
    编写 grunt 插件经验
    Sencha Touch 手机移动开发框架 HTML5 项目压缩方案;
    随笔 编辑推荐 上头条了, 贴出来做个记念!
    Javascript 俄罗斯方块 游戏代码解释!
    30天自制操作系统(NASM+GCC版)
    Logisim 打不开的解决方案(Windows10)
    Kali Linux 2020通过UEFI硬盘安装(免u盘)
    开源一个自制的ORM框架,基于Java原生JDBC(应该是全网首个吧)
    书单
    前端技术文章收集
  • 原文地址:https://www.cnblogs.com/chen20135517/p/7745499.html
Copyright © 2011-2022 走看看