zoukankan      html  css  js  c++  java
  • 抽屉原理

    Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain
    total number of sweets on that day, no matter how many children call on him, so it may happen that
    a child will get nothing if it is too late. To avoid con
    icts, the children have decided they will put
    all sweets together and then divide them evenly among themselves. From last year's experience of
    Halloween they know how many sweets they get from each neighbour. Since they care more about
    justice than about the number of sweets they get, they want to select a subset of the neighbours to
    visit, so that in sharing every child receives the same number of sweets. They will not be satis ed if
    they have any sweets left which cannot be divided.
    Your job is to help the children and present a solution.
    Input
    The input contains several test cases.
    The rst line of each test case contains two integers c and n (1 <= c<= n <= 100000), the number of
    children and the number of neighbours, respectively. The next line contains n space separated integers
    a1; : : : ; an (1 <= ai <= 100000), where ai represents the number of sweets the children get if they visit
    neighbour i.
    The last test case is followed by two zeros.
    Output
    For each test case output one line with the indices of the neighbours the children should select (here,
    index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where
    each child gets at least one sweet, print `no sweets' instead. Note that if there are several solutions
    where each child gets at least one sweet, you may print any of them.
    Sample Input
    4 5
    1 2 3 7 5
    3 6
    7 11 2 5 13 17
    0 0
    Sample Output
    3 5
    2 3 4

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    const int maxn=100000+5;
    typedef long long LL;
    LL a[maxn];
    LL mod[maxn] ;

    int main()
    {
        int m,n;
        while(~scanf("%d%d",&m,&n))
        {
            if(m==0 && n==0)
            break;
            memset(a,0,sizeof(a));
            int k;
            for(int i=1; i<=n; i++)
            //方法一
             // scanf("%d",&a[i]);//,mod[i]=-2;
            //memset(mod, -1, sizeof(mod));
            //mod[0]=-1;
            /*LL sum=0;
            for(int i=0; i<n; i++)
            {
                sum+=a[i];
                if(mod[sum%m]!=-2)
                {
                    for(int j=mod[sum%m]+1; j<=i; j++)
                    {
                        printf("%d",j+1);
                        if(i!=j)
                        printf(" ");
                    }
                    cout<<endl;
                    break;
                }
                mod[sum%m]=i;
            }*/
            {
                scanf("%d",&k);
                a[i]=a[i-1]+k;
            }
            memset(mod, 0, sizeof(mod));

            for(int i=1 ; i<=n; i++)
            {
                if(a[i]%m == 0)
                {
                    for(int j=1; j<=i; j++)
                    {
                        if(j == 1)
                            printf("%d",j);
                        else
                            printf(" %d",j);
                    }
                    cout<<endl;
                    break;
                }
                if(mod[a[i]%m] == 0)
                     mod[a[i]%m]=i;
                else
                {
                    for(int j=mod[a[i]%m]+1; j<=i; j++)
                    {
                        if(j == i)
                            cout<<j<<endl;
                        else
                            cout<<j<<" ";
                    }
                    break;
                }
            }
        }
        return 0;
    }

    第二讲课件代码模式:

     

  • 相关阅读:
    fgets()函数读取键盘,去掉换行符或丢弃多余的字符
    c语言gets()函数与它的替代者fgets()函数
    基于京东手机销售数据用回归决策树预测价格
    「我去,这也能行!」令人惊叹的8个深度学习应用
    常见数据结构的 Python 实现(建议收藏)
    60 分钟极速入门 PyTorch
    大牛推荐的15本学习数据分析挖掘的好书
    排名前20的网页爬虫工具
    如何11 周打造全能Python工程师!
    初学者的编程自学指南
  • 原文地址:https://www.cnblogs.com/chen9510/p/4702395.html
Copyright © 2011-2022 走看看