zoukankan      html  css  js  c++  java
  • 2015 HUAS Summer Trainning #4~D

    Given several segments of line (int the X axis) with coordinates [Li , Ri ]. You are to choose the minimal amount of them, such they would completely cover the segment [0, M].

    Input

    The first line is the number of test cases, followed by a blank line.

    Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri” (|Li |, |Ri | ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair ‘0 0’.

    Each test case will be separated by a single line.

    Output

    For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without quotes).

    Print a blank line between the outputs for two consecutive test cases.

    Sample Input

    2

    1

    -1 0

    -5 -3

    2 5

    0 0

    1

    -1 0

    0 1

    0 0

    Sample Output

    0

    1

    0 1

    解题思路:本题的突破口是区间包含和排序扫描,不过要先进行一次预处理。每个区间在给定的长度之外的部分都应该预先被切除,因为它们的存在是毫无意义的。在预处理之后,在相互包含的情况下小区间显然不应该考虑。把各区间按照a从小到大排序,若a相同,则b从大到小排序(自动处理掉区间包含),注意若区间1的起点大于s,则无解(其它区间的起点更大,不可能覆盖到s点)

    程序代码:

    #include <cstdio>
    #include <cstring>
    #include<iostream>
    #include <algorithm>
    using namespace std;
    int t;
    int st, e, qn, outn;
    struct M
    {   
     int start;   
     int end;
    } q[100005], out[100005];
    int cmp (M a, M b) //按最大能覆盖到排序
    {   
     return a.end > b.end;
    }
    int main()
    {   
     //'char s;
     scanf("%d", &t);
        //scanf("%c",&s);
     while (t --)
     { 
      qn = 0;
      outn = 0;
      st = 0; 
      scanf("%d", &e); 
      while (scanf("%d%d", &q[qn].start, &q[qn].end) && q[qn].start + q[qn].end)
      {    
       qn ++; 
      } 
      sort(q, q + qn, cmp); 
      while (st < e)
      {    
       int i;    
       for (i = 0; i < qn; i ++)
       {  
        if (q[i].start <= st && q[i].end > st)
        {     
         st = q[i].end;//更新区间     
         out[outn ++] = q[i];     
         break;  
        }    
       }    
       if (i == qn)
        break;//如果没有一个满足条件的区间,直接结束。 
      } 
      if (st < e)
       printf("0 "); 
      else
      {    
       printf("%d ", outn);    
       for (int i = 0; i < outn; i ++)  
        printf("%d %d ", out[i].start, out[i].end); 
      } 
      if (t)
       printf(" ");   
     }   
     return 0;
    }

  • 相关阅读:
    【codevs4919】线段树练习4
    【51Nod1405】树上距离和 二次扫描与换根法
    【洛谷P1717】钓鱼
    【洛谷P1230】智力大冲浪
    【洛谷P1248】加工生产调度
    hdu 1195(搜索)
    hdu 1181(Floyed)
    hdu 1250(大整数)
    hdu 1180(广搜好题)
    hdu 1099(数学)
  • 原文地址:https://www.cnblogs.com/chenchunhui/p/4709193.html
Copyright © 2011-2022 走看看