zoukankan      html  css  js  c++  java
  • General Problem Solving Techniques [Beginner-1]~F

           You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

           Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

    Input

    The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

    Output

    For each test case output, if s is a subsequence of t.

    Sample Input

    sequence subsequence

    person compression

    VERDI vivaVittorioEmanueleReDiItalia

    caseDoesMatter CaseDoesMatter

    Sample Output

    Yes

    No

    Yes

    No

    解题思路:题目的大概意思是给出每次两个字符,判断第一个字符串中的字母是否在第二个字符串中出现,需要注意的是,字符可以是不连续的但是顺序不能打乱。用一个循环依次判断至末尾就可以了。

    程序代码:

    #include<stdio.h>
    #include<string.h>
    const int N=100010;
    char a[N],b[N];
    int main()
    {
    int i,j;
    while(scanf("%s%s",&a,&b)!=EOF)
    {
    for(i=0,j=0;a[i]!=''&&b[j]!='';j++)
    if(a[i]==b[j]) i++;
    if(a[i]=='') printf("Yes ");
    else printf("No ");
    }
    return 0;
    }

  • 相关阅读:
    正则表达式
    对象与私有成员变量恩仇录
    c语言,中缀表达式转后缀表达式并计算
    Graphics Class
    获取当前应用程序所在目录的路径
    centos安装vim
    Linux更改IP地址
    Linux常用命令
    Linux添加环境变量
    Linux虚拟机安装
  • 原文地址:https://www.cnblogs.com/chenchunhui/p/4820280.html
Copyright © 2011-2022 走看看