zoukankan      html  css  js  c++  java
  • nyoj 220——推桌子——————【贪心】

    推桌子

    时间限制:1000 ms  |  内存限制:65535 KB
    难度:3
     
    描述
    The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

    The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

    For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
     
    输入
    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
    Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
    line, the remaining test cases are listed in the same manner as above.
    输出
    The output should contain the minimum time in minutes to complete the moving, one per line.
    样例输入
    3 
    4 
    10 20 
    30 40 
    50 60 
    70 80 
    2 
    1 3 
    2 200 
    3 
    10 100 
    20 80 
    30 50
    样例输出
    10
    20
    30

    题目大意:让你搬桌子,但是走廊太窄,某段走廊只能一次移动一个桌子,两个相对的房间对应同一个走廊号。每次搬运花费10分钟,问最少需耗费多少分钟。其实问的就是次数。

    解题思路:
    方法1:其实就是重叠度的问题。重叠度越高,需要的次数就越多。可以让每次搬运经过的走廊号对应的变量都自加,最后统计所有走廊号对应变量大小,其中最大的就是需要搬运的最少次数。
    方法2:按照选择不相交区间的思想来做。但是这个需要按照左端点从小到大排序,然后挑出第一个没选择过的区间的右端点作为比较值,以挑出的那个区间为衡量选出所有不相交的区间,表示需搬运一次。然后重复挑选。最后挑选了几次,表示需要搬运几次。

    1:
    //方法1
    #include<bits/stdc++.h>
    using namespace std;
    int corridor[210];
    int main(){
        int t,n,m,i,j,k,cnt,tmp,a,b;
        scanf("%d",&t);
        while(t--){
            memset(corridor,0,sizeof(corridor));
            scanf("%d",&n);
            for(i=0;i<n;i++){
                scanf("%d%d",&a,&b);
                a=(a+1)/2,b=(b+1)/2;
                if(a>b){
                    tmp=a;
                    a=b;
                    b=tmp;
                }
                for(j=a;j<=b;j++){
                    corridor[j]++;
                }
            }
            cnt=0;
            for(i=1;i<=202;i++){
                cnt>corridor[i]? :cnt=corridor[i];
            }
            cout<<cnt*10<<endl;
        }
        return 0;
    }
    

      2:

     //方法2
    #include<bits/stdc++.h>
    using namespace std;
    struct SEG{
        int left,right;
        int used;
        SEG(){
            used=0;
        }
    }seg[500];
    bool cmp(SEG a,SEG b){
        if(a.left!=b.left)
            return a.left<b.left;
    }
    int main(){
    //    freopen("Input.txt","r",stdin);
    //    freopen("OUT.txt","w",stdout);
        int t,n,m,i,j,k,num,cnt,a,b,pos;
        scanf("%d",&t);
        while(t--){
            scanf("%d",&n);
            for(i=0;i<n;i++){
                scanf("%d%d",&a,&b);
                a=(a+1)/2,b=(b+1)/2;
                a>b?a=a+b,b=a-b,a=a-b:0;
                seg[i].left=a,seg[i].right=b;
            }
            sort(seg,seg+n,cmp);
            num=0,cnt=0;
            while(cnt<n){
                for(i=0;i<n;i++){
                    if(seg[i].used==0){
                        pos=i;
                        break;
                    }
                }
                seg[pos].used=1;
                cnt++;
                num++;
                for(i=1;i<n;i++){
                    if(!seg[i].used){
                        if(seg[pos].right<seg[i].left){
                            pos=i;
                            seg[i].used=1;
                            cnt++;
                        }
                    }
                }
            }
            cout<<num*10<<endl;
            for(i=0;i<500;i++)
                seg[i].used=0;
        }
        return 0;
    }
            
    

      




  • 相关阅读:
    Tomcat 生产服务器性能优化
    ExtJs3常用控件操作实例
    vss报错Workgroup无法访问,您可能没有权限使用网络资源解决办法
    Java Socket Example
    正则表达式:根据逗号解析CSV并忽略引号内的逗号
    java打jar包 命令行cmd在当前路径打jar包
    【Java/Json】Java对Json进行建模,分词,递归向下解析构建Json对象树
    【Json】Json分词器
    【java/Json】用Java对象构建Json语法树
    【Java文件】按UTF-8编码读取文本文件(逐行方式),排序,打印到控制台
  • 原文地址:https://www.cnblogs.com/chengsheng/p/4629658.html
Copyright © 2011-2022 走看看