zoukankan      html  css  js  c++  java
  • poj 1422(二分图)

    比较基础的二分图。

    因为没有环路, 每个十字路口只能通过一个伞兵, 所以可以用最大匹配来做。 也就是对于每一条街道,如果选择了,那么就可以减少一个伞兵。

    Air Raid
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 5800   Accepted: 3464

    Description

    Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles. 
    With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper. 

    Input

    Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format: 
    no_of_intersections  no_of_streets  S1 E1  S2 E2  ......  Sno_of_streets Eno_of_streets 
    The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections. 
    There are no blank lines between consecutive sets of data. Input data are correct. 

    Output

    The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town. 

    Sample Input

    2
    4
    3
    3 4
    1 3
    2 3
    3
    3
    1 3
    1 2
    2 3

    Sample Output

    2
    1

    Source

    Dhaka 2002
    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    using namespace std;
    #define N 122
    int n,m;
    
    int g[N][N];
    int mark[N],pre[N];
    
    int dfs(int s)
    {
        for(int i=1;i<=n;i++)
        {
            if(g[s][i]==0||mark[i]==1) continue;
            mark[i]=1;
            if(pre[i]==-1||dfs(pre[i]))
            {
                pre[i]=s;
                return 1;
            }
        }
        return 0;
    }
    
    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            memset(g,0,sizeof(g));
            scanf("%d%d",&n,&m);
            for(int i=0;i<m;i++)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                g[x][y]=1;
            }
            memset(pre,-1,sizeof(pre));
            int sum=0;
            for(int i=1;i<=n;i++)
            {
                memset(mark,0,sizeof(mark));
                sum+=dfs(i);
            }
            printf("%d\n",n-sum);
        }
        return 0;
    }
  • 相关阅读:
    legend3---2、网站的代码里面的/也是代表根目录
    legend3---PHP使用阿里云短信服务
    legend3---laravel验证码使用
    好用网站推荐
    The practice program of C on point
    Android自己定义组件系列【9】——Canvas绘制折线图
    网络流24题 之十四 孤岛营救问题 分层图
    关于安卓你不知道的6件事
    OpenStack_Swift源代码分析——Ring基本原理及一致性Hash算法
    Codeforces554D:Kyoya and Permutation
  • 原文地址:https://www.cnblogs.com/chenhuan001/p/3035067.html
Copyright © 2011-2022 走看看