zoukankan      html  css  js  c++  java
  • poj 2942(点的双联通+染色)

     先求出点的双联通分量,每个分量可以看成一系列相邻的环, 且只要在一个联通分量发现奇数环那么这个分量的所有点都在奇环中.

    Knights of the Round Table
    Time Limit: 7000MS   Memory Limit: 65536K
    Total Submissions: 7598   Accepted: 2358

    Description

    Being a knight is a very attractive career: searching for the Holy Grail, saving damsels in distress, and drinking with the other knights are fun things to do. Therefore, it is not very surprising that in recent years the kingdom of King Arthur has experienced an unprecedented increase in the number of knights. There are so many knights now, that it is very rare that every Knight of the Round Table can come at the same time to Camelot and sit around the round table; usually only a small group of the knights isthere, while the rest are busy doing heroic deeds around the country. 

    Knights can easily get over-excited during discussions-especially after a couple of drinks. After some unfortunate accidents, King Arthur asked the famous wizard Merlin to make sure that in the future no fights break out between the knights. After studying the problem carefully, Merlin realized that the fights can only be prevented if the knights are seated according to the following two rules:
    • The knights should be seated such that two knights who hate each other should not be neighbors at the table. (Merlin has a list that says who hates whom.) The knights are sitting around a roundtable, thus every knight has exactly two neighbors.
    • An odd number of knights should sit around the table. This ensures that if the knights cannot agree on something, then they can settle the issue by voting. (If the number of knights is even, then itcan happen that ``yes" and ``no" have the same number of votes, and the argument goes on.)
    Merlin will let the knights sit down only if these two rules are satisfied, otherwise he cancels the meeting. (If only one knight shows up, then the meeting is canceled as well, as one person cannot sit around a table.) Merlin realized that this means that there can be knights who cannot be part of any seating arrangements that respect these rules, and these knights will never be able to sit at the Round Table (one such case is if a knight hates every other knight, but there are many other possible reasons). If a knight cannot sit at the Round Table, then he cannot be a member of the Knights of the Round Table and must be expelled from the order. These knights have to be transferred to a less-prestigious order, such as the Knights of the Square Table, the Knights of the Octagonal Table, or the Knights of the Banana-Shaped Table. To help Merlin, you have to write a program that will determine the number of knights that must be expelled. 

    Input

    The input contains several blocks of test cases. Each case begins with a line containing two integers 1 ≤ n ≤ 1000 and 1 ≤ m ≤ 1000000 . The number n is the number of knights. The next m lines describe which knight hates which knight. Each of these m lines contains two integers k1 and k2 , which means that knight number k1 and knight number k2 hate each other (the numbers k1 and k2 are between 1 and n ). 

    The input is terminated by a block with n = m = 0 . 

    Output

    For each test case you have to output a single integer on a separate line: the number of knights that have to be expelled. 

    Sample Input

    5 5
    1 4
    1 5
    2 5
    3 4
    4 5
    0 0
    

    Sample Output

    2

    Hint

    Huge input file, 'scanf' recommended to avoid TLE. 

    Source

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    using namespace std;
    #define N 1010
    #define M 1001000
    #define INF 0x3ffffff
    
    bool g[N][N];
    int n,m;
    int num;
    int low[N];
    int save[N][N];
    int stack[N];
    int mark[N];
    int ans[N];
    int top;
    int flag;
    
    // 求点双联通分量
    
    void dfs(int s,int cnt)
    {
        low[s]=cnt;
        stack[++top]=s;
        int mi=INF;
        for(int i=1;i<=n;i++)
        {
            if(g[s][i]==0||i==s) continue;
            if(low[i]==-1)
            {
                dfs(i,cnt+1);
                if(low[i]>=cnt) // 这个点是割点
                {
                    save[num][s]=1;
                    do
                    {
                        save[num][ stack[top] ] = 1;
                    }while(stack[top--]!=i);
                    num++;
                }
            }
            mi=min(mi,low[i]);
        }
        low[s]=mi;
    }
    
    void ldfs(int front,int s,int f,int k)
    {
        if(flag==1) return ;
        mark[s]=f;
        for(int i=1;i<=n;i++)
        {
            if(g[s][i]==1&&save[k][i]==1&&i!=front&&i!=s)
            {
                if(mark[i]==-1)
                {
                    ldfs(s,i,f^1,k);
                }
                else
                {
                    if(mark[i]==f)
                    {
                        flag=1;
                        return ;
                    }
                }
            }
        }
    }
    
    int main()
    {
        while(scanf("%d%d",&n,&m)&&(n+m))
        {
            num=0; top=0;
            memset(g,0,sizeof(g));
            memset(save,0,sizeof(save));
            memset(low,-1,sizeof(low));
            for(int i=0;i<m;i++)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                g[x][y]=g[y][x]=1;
            }
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                {
                    g[i][j]=g[i][j]^1;
                }
            for(int i=1;i<=n;i++)
            {
                if(low[i]==-1)
                    dfs(i,0);
            }
            memset(ans,0,sizeof(ans));;
            for(int i=0;i<num;i++)
            {
                memset(mark,-1,sizeof(mark));
                for(int j=1;j<=n;j++)
                    if(save[i][j]==1)
                    {
                        flag=0;
                        ldfs(0,j,0,i);
                        if(flag==1)
                        {
                            for(int j1=1;j1<=n;j1++)
                            {
                                if(save[i][j1]==1)
                                    ans[j1]=1;
                            }
                        }
                        break;
                    }
            }
            int acnt=0;
            for(int i=1;i<=n;i++)
                acnt+=(ans[i]^1);
            printf("%d\n",acnt);
        }
        return 0;
    }
  • 相关阅读:
    前端三剑客之css 后续
    前端三剑客之css
    优酷项目遇到的知识点回顾
    MySQL 里 视图,触发器,事物,存储过程,内置函数,流程控制,索引
    mysql的用户管理
    数据库管理工具 navicat 相关的练习
    MySQL 单表查询,多表查询
    MySQL 外键 表与表的关系 多对一,多对多,一对一,表的修改 与 复制
    ORM基础
    Django路由系统
  • 原文地址:https://www.cnblogs.com/chenhuan001/p/3084201.html
Copyright © 2011-2022 走看看