Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 12802 | Accepted: 4998 |
Description
The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input
2 3 4 5 0
Sample Output
1 3 5 9
Source
POJ Contest,Author:Mathematica@ZSU
![](https://images.cnblogs.com/OutliningIndicators/ContractedBlock.gif)
/** 题意:求F[i] 的元素的个数,并且0<a<b<=i, gcd(a,b)=1 做法:欧拉 用phi[n]存储小于等于n的素数的个数,然后f[i] = phi[i] + f[i] **/ #include <iostream> #include <string.h> #include <cmath> #include <algorithm> #include <stdio.h> #define maxn 1000100 using namespace std; long long mmap[maxn]; int phi[maxn]; long long n; void geteuler() { memset(phi,0,sizeof(phi)); phi[1] = 1; for(int i=2; i<=maxn; i++) { if(!phi[i]) { for(int j=i; j<=maxn; j+=i) { if(!phi[j]) phi[j] = j; phi[j] = phi[j]/i*(i-1); } } } } int main() { geteuler(); mmap[1] = 0; for(int i=2; i<=maxn; i++) { mmap[i] = mmap[i-1] + phi[i]; } //freopen("in.txt","r",stdin); while(~scanf("%lld",&n)) { if(n == 0) break; printf("%lld ",mmap[n]); } return 0; }