zoukankan      html  css  js  c++  java
  • C

    Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao Cao's army. But all generals and soldiers of Cao Cao were loyal, it's impossible to convince any of them to betray Cao Cao. 

    So there is only one way left for Yu Zhou, send someone to fake surrender Cao Cao. Gai Huang was selected for this important mission. However, Cao Cao was not easy to believe others, so Gai Huang must leak some important information to Cao Cao before surrendering. 

    Yu Zhou discussed with Gai Huang and worked out NN information to be leaked, in happening order. Each of the information was estimated to has aiai value in Cao Cao's opinion. 

    Actually, if you leak information with strict increasing value could accelerate making Cao Cao believe you. So Gai Huang decided to leak exact MM information with strict increasing value in happening order. In other words, Gai Huang will not change the order of the NN information and just select MM of them. Find out how many ways Gai Huang could do this.

    InputThe first line of the input gives the number of test cases, T(1100)T(1≤100). TT test cases follow. 

    Each test case begins with two numbers N(1N103)N(1≤N≤103) and M(1MN)M(1≤M≤N), indicating the number of information and number of information Gai Huang will select. Then NN numbers in a line, the ithithnumber ai(1ai109)ai(1≤ai≤109) indicates the value in Cao Cao's opinion of the ithith information in happening order.
    OutputFor each test case, output one line containing Case #x: y, where xx is the test case number (starting from 1) and yy is the ways Gai Huang can select the information. 

    The result is too large, and you need to output the result mod by 1000000007(109+7)1000000007(109+7).
    Sample Input

    2
    3 2
    1 2 3
    3 2
    3 2 1

    Sample Output

    Case #1: 3
    Case #2: 0
    
            
     

    Hint

    In the first cases, Gai Huang need to leak 2 information out of 3. He could leak any 2 information as all the information value are in increasing order. 
    In the second cases, Gai Huang has no choice as selecting any 2 information is not in increasing order.
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    const int maxn=100010;
    const int mod=1e9+7;
    int a[maxn],lsh[maxn];
    int n,m;
    int dp[1010][1010];
    int lowbit(int x)
    {
        return x&-x;
    }
    void add(int x,int y,ll val)
    {
        for(int i=x;i<=n;i+=lowbit(i)){
            dp[i][y]=(dp[i][y]+val)%mod;
        }
    }
    int sum(int x,int y)
    {
        int ans=0;
        for(int i=x;i>=1;i-=lowbit(i)){
            ans=(ans+dp[i][y])%mod;
        }
        return ans;
    }
    int main()
    {
        ios::sync_with_stdio(0);
        int T,k=1;
        cin>>T;
        while(T--){
            memset(dp,0,sizeof(dp));
            cin>>n>>m;
            for(int i=1;i<=n;i++){
                cin>>a[i];
                lsh[i]=a[i];
            }
            sort(lsh+1,lsh+1+n);
    //        int len=unique(lsh+1,lsh+1+n)-lsh-1;//去不去重都一样啦,下面是lowerbound
            for(int i=1;i<=n;i++){
                int x=lower_bound(lsh+1,lsh+1+n,a[i])-lsh;
                add(x,1,1);
                for(int j=2;j<=m;j++){
                    add(x,j,sum(x-1,j-1));
                }
            }
            cout<<"Case #"<<k++<<": ";
            cout<<sum(n,m)<<endl;
        }
        return 0;
    }


  • 相关阅读:
    Java 7 中 NIO.2 的使用——第二节 元数据文件的属性
    Java 7 中 NIO.2 的使用——第一节 Path 类的使用
    使用第三方工具覆写Object中方法
    Java Synchronized Blocks vs. Methods
    生如夏花,死如秋叶
    Struts2中的ModelDriven机制及其运用(转)
    Java 调用 Javascript 函数的范例
    枚举实现工厂模式
    使用Java 8 Lambda表达式对Employee类进行操作
    自定义异常时如何定义checked异常和unchecked异常
  • 原文地址:https://www.cnblogs.com/cherish-lin/p/11323735.html
Copyright © 2011-2022 走看看