zoukankan      html  css  js  c++  java
  • 微软2014实习生及秋令营技术类职位在线测试(题目1 : String reorder)

    题目1 : String reorder

    时间限制:10000ms
    单点时限:1000ms
    内存限制:256MB

    Description

    For this question, your program is required to process an input string containing only ASCII characters between ‘0’ and ‘9’, or between ‘a’ and ‘z’ (including ‘0’, ‘9’, ‘a’, ‘z’).

    Your program should reorder and split all input string characters into multiple segments, and output all segments as one concatenated string. The following requirements should also be met,
    1. Characters in each segment should be in strictly increasing order. For ordering, ‘9’ is larger than ‘0’, ‘a’ is larger than ‘9’, and ‘z’ is larger than ‘a’ (basically following ASCII character order).
    2. Characters in the second segment must be the same as or a subset of the first segment; and every following segment must be the same as or a subset of its previous segment.

    Your program should output string “<invalid input string>” when the input contains any invalid characters (i.e., outside the '0'-'9' and 'a'-'z' range).


    Input


    Input consists of multiple cases, one case per line. Each case is one string consisting of ASCII characters.

    Output


    For each case, print exactly one line with the reordered string based on the criteria above.


    样例输入
    aabbccdd
    007799aabbccddeeff113355zz
    1234.89898
    abcdefabcdefabcdefaaaaaaaaaaaaaabbbbbbbddddddee
    样例输出
    abcdabcd
    013579abcdefz013579abcdefz
    <invalid input string>
    abcdefabcdefabcdefabdeabdeabdabdabdabdabaaaaaaa
    用map比较好,这个程序耗时太多,哎。。。
    代码如下:
    #include <iostream>
    //#include <map>
    #include <vector>
    #include <list>
    #include <algorithm>
    #include <string>
    using namespace std;
    
    bool checkstr(string a)
    {
    	for (unsigned int i=0;i<a.size();i++)
    	{
    		if (a[i]<'0'||a[i]>'z'||('9'<a[i]&&a[i]<'a'))
    		{
    			return false;
    		}
    	}
    	return true;
    }
    
    int main()
    {
    	string sa;
    	vector<string> va;
    	list<char>::iterator it1;
    	//while(cin>>sa)
    	while(getline(cin,sa))
    	{
    		va.push_back(sa);
    	}
    	vector<list<char> > la(va.size());
    	
    	for (unsigned int i=0;i<va.size();i++)
    	{
    		for (unsigned int j=0;j<va[i].size();j++)
    		{
    			la[i].push_back(va[i][j]);
    		}
    		la[i].sort();
    	}
    
    	for (unsigned int i=0;i<va.size();i++)
    	{
    		if (checkstr(va[i]))
    		{
    			char temp;
    			it1=la[i].begin();
    			while (!la[i].empty())
    			{
    				cout<<*it1;
    				temp=*it1;
    				it1=la[i].erase(it1);
    				if (it1==la[i].end()&&!la[i].empty())
    				{
    					it1=la[i].begin();
    
    				}
    				while(!la[i].empty()&&*it1==temp)
    				{
    					++it1;
    					if (it1==la[i].end()&&!la[i].empty())
    					{
    						it1=la[i].begin();
    					}
    				}
    			}
    			cout<<endl;
    		}
    		else
    			cout<<"<invalid input string>"<<endl;
    	}
    
    	//system("pause");
    	return 0;
    }

  • 相关阅读:
    用友跨账套查询
    用友单据导入
    Delphi Math单元函数
    9.golang 字符串操作
    7.golang 结构体和指针
    6.golang 数组,切片,映射
    5.golang 控制流程 if, else if ,switch ,defer使用
    golang 指针类型* ,以及 &取变量内存地址
    phpjwt 第三方库生成token验证,也可以做公钥,私钥的验证方法。
    golang采坑一 expected ';', found 'import'
  • 原文地址:https://www.cnblogs.com/chhuach2005/p/3961700.html
Copyright © 2011-2022 走看看