zoukankan      html  css  js  c++  java
  • 杭电ACM1.2.3 QuickSum

    Quicksum

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1712 Accepted Submission(s): 1122
     

    Problem Description

    A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

    For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

    A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

    ACM: 1*1 + 2*3 + 3*13 = 46MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

     

    Input

    The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

     

    Output

    For each packet, output its Quicksum on a separate line in the output.

     

    Sample Input

    ACM

    MID CENTRAL

    REGIONAL PROGRAMMING CONTEST

    ACN

    A C M

    ABC

    BBC

    #

     

    Sample Output

    46

    650

    4690

    49

    75

    14

    15

    代码:

    #include <iostream>
    #include "stdio.h"
    #include "string.h"
    #include "ctype.h"
    using namespace std;
    
    int main()
    {
        char c[255];
        int total;
        while(gets(c)&&c[0]!='#')
        {
            total = 0 ;
            for(int j = 0 ; j < strlen(c) ; j++)
            {
                if(c[j]!=' ')
                total +=(((int)c[j]-64)*(j+1));
            }
            cout<<total<<endl;
        }
        return 0;
    }
  • 相关阅读:
    如何将伪数组转换成真正的数组
    JS 中对变量类型的五种判断方法
    ajax详解
    onload和ready的区别
    ES5继承
    跨域的三种解决方式
    如何处理使用js兼容所有浏览器的问题
    Canvas修行之黑客帝国代码雨
    Webpack+React+ES6入门指南[转]
    对于Mongodb数据库的学习
  • 原文地址:https://www.cnblogs.com/cityflickr/p/3133041.html
Copyright © 2011-2022 走看看