zoukankan      html  css  js  c++  java
  • PAT(A) 1062. Talent and Virtue (25)

    About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

    Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

    Input Specification:

    Each input file contains one test case. Each case first gives 3 positive integers in a line: N (<=105), the total number of people to be ranked; L (>=60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

    Then N lines follow, each gives the information of a person in the format:

    ID_Number Virtue_Grade Talent_Grade
    

    where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

    Output Specification:

    The first line of output must give M (<=N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

    Sample Input:

    14 60 80
    10000001 64 90
    10000002 90 60
    10000011 85 80
    10000003 85 80
    10000004 80 85
    10000005 82 77
    10000006 83 76
    10000007 90 78
    10000008 75 79
    10000009 59 90
    10000010 88 45
    10000012 80 100
    10000013 90 99
    10000014 66 60
    

    Sample Output:

    12
    10000013 90 99
    10000012 80 100
    10000003 85 80
    10000011 85 80
    10000004 80 85
    10000007 90 78
    10000006 83 76
    10000005 82 77
    10000002 90 60
    10000014 66 60
    10000008 75 79
    10000001 64 90
    
    #include <cstdio>
    #include <cstring>
    #include <algorithm>    //sort()
    using namespace std;
    /*  de<L || cai<L               为第五类
        de>=H && cai>=H             为第一类
        de>=H && cai<H             为第二类
        de<H && cai<H && de>=cai    为第三类
        其他                        为第四类
    
        从小到大排序:
        1. 按类别
        2. 类别相同的,按总分
        3. 总分相同的,按德分
        4. 德分相同的,按准考证号
    */
    
    struct Student{
        char id[10];        //准考证号
        int de, cai, sum;   //德,才,总分
        int flag;           //考生类别(5类)
    }stu[100010];
    
    bool cmp(Student a, Student b){     //划重点(1): 自定义sort()按cmp()方式排序
        if(a.flag!=b.flag)      return a.flag < b.flag;     //类别小的在前
        else if(a.sum!=b.sum)   return a.sum > b.sum;      //类别相同时,总分大的在前
        else if(a.de!=b.de)     return a.de > b.de;         //总分相同时,德分大的在前
        else return strcmp(a.id, b.id)<0;                   //德分相同时,准考证号小的在前
        //划重点(2): strcmp(a, b)比较两个字符串大小
    }
    
    int main()
    {
        int n, L, H;
        scanf("%d%d%d", &n, &L, &H);
        int m=n;    //m为及格人数
        for(int i=0; i<n; i++){
            scanf("%s%d%d", &stu[i].id, &stu[i].de, &stu[i].cai);
            stu[i].sum=stu[i].de+stu[i].cai;    //计算总分
    //步骤(1): 对学生进行分类 if(stu[i].de<L || stu[i].cai<L){ stu[i].flag=5; //先将不及格者设为第五类 m--; //及格人数-1 } else if(stu[i].de>=H && stu[i].cai>=H) stu[i].flag=1; else if(stu[i].de>=H && stu[i].cai<H) stu[i].flag=2; else if(stu[i].de>=stu[i].cai) stu[i].flag=3; else stu[i].flag=4; //第四类情况最多,故放在后面 } //步骤(2): 排序 sort(stu, stu+n, cmp); //步骤(3): 输出 printf("%d ", m); for(int i=0; i<m; i++){ printf("%s %d %d ", stu[i].id, stu[i].de, stu[i].cai); } return 0; }
  • 相关阅读:
    poj 3070 矩阵快速乘
    将数字放大显示
    hdu 火车入队 stack
    linq to Entity 数据库除了有主键还有唯一索引,是不是不能更新
    整理:C#写ActiveX, 从代码到打包到签名到发布的示例
    Java—FileOperator
    第二章-递归与分治策略
    第四章-贪心算法
    第五章-回溯法
    Linux中C程序调试、makefile
  • 原文地址:https://www.cnblogs.com/claremore/p/6549299.html
Copyright © 2011-2022 走看看