zoukankan      html  css  js  c++  java
  • 3-4 计算长方形的周长和面积

    3-4 计算长方形的周长和面积

    Time Limit: 1000MS Memory limit: 65536K

    题目描写叙述

    通过本题的练习能够掌握拷贝构造函数的定义和用法。
    设计一个长方形类Rect。计算长方形的周长与面积。

    类中有私有数据成员Length(长)、Width(宽),由具有缺省參数值的构造函数对其初始化,函数原型为:Rect(double Length=0, double Width=0); 再为其定义拷贝构造函数,形參为对象的常引用,函数原型为:Rect(const Rect &); 编写主函数,创建Rect对象r1初始化为长、宽数据,利用r1初始化还有一个Rect对象r2。分别输出对象的长和宽、周长和面积。

     
     
    要求: 创建对象 Rect r1(3.0,2.0),r2(r1);

    输入

    输入两个实数,中间用一个空格间隔。代表长方形的长和宽

    输出

    共同拥有6
    分别输出r1的长和宽。 r1的周长; r1的面积;r2的长和宽。 r2的周长。 r2的面积;注意单词与单词之间用一个空格间隔

    演示样例输入

    56 32

    演示样例输出

    the length and width of r1 is:56,32
    the perimeter of r1 is:176
    the area of r1 is:1792
    the length and width of r2 is:56,32
    the perimeter of r2 is:176
    the area of r2 is:1792

    提示

     

    输入 -7.0 -8.0

    输出

    the length and width of r1 is:0,0

    the perimeter of r1 is:0

    the area of r1 is:0

    the length and width of r2 is:0,0

    the perimeter of r2 is:0

    the area of r2 is:0

    来源

     黄晶晶

    演示样例程序



    #include <iostream>
    using namespace std;
    class Rect
    {
    private:
        double len;
        double wid;
    public:
        Rect(double x=0,double y=0);
        Rect(const Rect &b);
        const void display()
        {
            cout << "the length and width of r1 is:" << len << ","<< wid << endl;
            cout << "the perimeter of r1 is:" << (len + wid) * 2<<endl;
            cout << "the area of r1 is:" << len * wid << endl;
        }
        const void display1()
        {
            cout << "the length and width of r2 is:" << len << ',' << wid<< endl;
            cout << "the perimeter of r2 is:" << (len + wid) * 2 << endl;
            cout << "the area of r2 is:" << len * wid << endl;
        }
    };
    Rect::Rect(double x,double y)
    {
        len=x;
        wid=y;
    }
    Rect::Rect(const Rect &b)
    {
        len=b.len;
        wid=b.wid;
    }
    int main()
    {
        double x,y;
        cin>>x>>y;
        if(x<0||y<0)
        {
            x=0;
            y=0;
    
        }
        Rect rect(x,y);
        Rect rect1=rect;
        rect.display();
        rect1.display1();
        return 0;
    }
    

    
  • 相关阅读:
    Postgresql
    Partitioning with PostgreSQL v11 (转发)
    Partitioning with PostgreSQL v11 (转发)
    What is Data Partitioning?(转发)(未完待续)
    How to use table partitioning to scale PostgreSQL(转发)
    PostgreSQL 创建分区表(转发)
    json vs jsonb
    性能不佳的多线程应用程序的常见模式(microsoft)
    提高.net程序性能和稳定性-CLR Profile(转发)
    检查c#代码内存泄露工具-CLR Profiler工具使用(转发)
  • 原文地址:https://www.cnblogs.com/clnchanpin/p/7275255.html
Copyright © 2011-2022 走看看