zoukankan      html  css  js  c++  java
  • HDU 1711 -Number Sequence(KMP)

    题目

    Number Sequence

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 40385    Accepted Submission(s): 16656



    Problem Description

    Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

     


    Input

    The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].

     


    Output

    For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

     


    Sample Input

    2
    13 5
    1 2 1 2 3 1 2 3 1 3 2 1 2
    1 2 3 1 3
    13 5
    1 2 1 2 3 1 2 3 1 3 2 1 2
    1 2 3 2 1

     


    Sample Output

    6
    -1

    代码

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    const int MAXN=1e6 + 10;
    int a[MAXN],b[MAXN];
    int nxt[MAXN];
    int n,m;
    void getnxt()
    {
        int i=1;
        int j=0;
        nxt[0]=0;
        while(i<m)
        {
            if(b[i]==b[j])
            {
                nxt[i++]=++j;
            }
            else if(!j)
            {
                i++;
            }
            else
            {
                j=nxt[j-1];
            }
        }
    }
    int kmp()
    {
        int i=0;
        int j=0;
        while(i<n && j<m)
        {
            if(a[i]==b[j])
            {
                i++;
                j++;
            }
            else if(!j)
            {
                i++;
            }
            else
            {
                j=nxt[j-1];
            }
        }
        if(j==m) return i-m+1;
        else return -1;
    }
    int main()
    {
        int t,i,k;  
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d%d",&n,&m);
            for(i=0;i<n;i++)
            scanf("%d",&a[i]);
            for(i=0;i<m;i++)
            scanf("%d",&b[i]);
            getnxt();
            cout<<kmp()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    C# 中的EventHandler
    Leetcode:Combinations 组合
    Leetcode:Minimum Path Sum
    [LeetCode] Container With Most Water
    一个数n的最少可以由多少个数的平方和组成
    单链表的归并排序
    几个常用的操作系统进程调度算法(转)
    字符串的最长重复子串(转)
    linux静态链接库与动态链接库详解
    简易的hashtable实现
  • 原文地址:https://www.cnblogs.com/cnlik/p/11851868.html
Copyright © 2011-2022 走看看